Re: XPA-3 bug: Verify op. in Main program ignores the display-mode property


Avgerinos
 

Hi Govert and thanks for the workaround.


Yes, you 're right, it happens only the first time

And no, I stopped reporting to them lately.

I prefer to post all bugs here where at least there is some feedback and verification

If MSE is interested, they can always check this forum (the only place I could find Magic-support for the last 25 years ;-).


Avgerinos

On 26/1/2017 10:32 πμ, Govert Schipper wrote:

Hi Avgerinos,


You are right: I didn't test it in the Runtime, only Studio.

Because of my curious nature, I did some more tests.

What I found is that only the very first Verify in the Main Program is always displayed in a Box.

No matter if you put it directly in the Task Prefix, or in an Event Handler, or in a Subtask.

All consecutive Verify's are properly displayed according to the setting of 'Display in'.

A workaround could be to put the Verify in a separate program and call this program from the Main Program.

Will you report this to MSE as a bug?


Govert


Van: main@magicu-l.groups.io <main@magicu-l.groups.io> namens Avgerinos <mento@...>
Verzonden: vrijdag 20 januari 2017 23:39
Aan: main@magicu-l.groups.io
Onderwerp: Re: [magicu-l] XPA-3 bug: Verify op. in Main program ignores the display-mode property
 

I can even guess why it's working only within Studio ;-)


XPA seems to have issues in a basic sector:

Testing something in Studio's Runtime does not assure you that your Client will see the same in his plain Runtime


Avgerinos

On 21/1/2017 12:32 πμ, Avgerinos wrote:

Hi Govert


Did you try on the Runtime on it's own?


It is working only when you open the Runtime within Studio.

It is not working when you run the Runtime normally, on its own.


Regards

Avgerinos


On 20/1/2017 1:40 μμ, Govert Schipper wrote:

No problems here (3.1). Works as expected.




Van: main@magicu-l.groups.io <main@magicu-l.groups.io> namens Avgerinos <mento@...>
Verzonden: vrijdag 20 januari 2017 08:08
Aan: main@magicu-l.groups.io
Onderwerp: [magicu-l] XPA-3 bug: Verify op. in Main program ignores the display-mode property
 
Hi magicians

Documenting an issue noticed in XPA3 (tested up to 3.2)

A Verify operation in MAIN program's TaskPrefix always ignores the
property "Display=Status"
Instead it is always shown as a popup-alert
That was not the behavior in uniPaaS 1.9

Anyone else noticed it?

Regards
Avgerinos






Join main@magicu-l.groups.io to automatically receive all group messages.