Re: XPA 2.5e system.windows.forms.webbrowser vs activex-webbrowser


Sabrina Horst
 

Hi Frederik.

Subform implemented, but same behaviour.

As soon as the webbrowser.navigate(url) is done it will park and stay there.

 

 

Van: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] Namens Frederik Soete
Verzonden: maandag 21 augustus 2017 12:13
Aan: main@magicu-l.groups.io
Onderwerp: Re: [magicu-l] XPA 2.5e system.windows.forms.webbrowser vs activex-webbrowser

 

Hi,

 

Since last I responded, I have briefly used your great idea of pdf viewing through the dot net control. I have seen that those properties are indeed lacking. You can try to work around that issue by replacing the webbrowser by a subform (that does have those properties I mentioned), and then putting the webbrowser in the subform. In that way I think it will work.

 

Hope that helps,

 

Frederik Soete

 

 

 

Op 21 aug. 2017 08:45 schreef "Sabrina Horst" <s.horst@...>:

Thx Frederik.

These I have already set to No.

 

Still problem of parking.

 

Van: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] Namens Frederik Soete
Verzonden: donderdag 17 augustus 2017 17:01
Aan: main@magicu-l.groups.io
Onderwerp: Re: [magicu-l] XPA 2.5e system.windows.forms.webbrowser vs activex-webbrowser

 

Hi,

 

I do not have access to my XPA studio now, but after opening the form, then selecting the DotNet control properties, check if you can change 'allow park' or 'tab into' (near the bottom) to something more suitable. I hope those properties are available to you, and solve the parking problem.

 

Bye,

 

Frederik Soete

 

Op 17 aug. 2017 09:27 schreef "Sabrina Horst" <s.horst@...>:

Previous versions (v9, UP)  I would use the activex-webbrowser to preview documents (pdf f.e.)
XPA does not allow activex so I altered the preview to the .Net webbrowser (SWF.Webbrowser).

There is a difference in behavior. 
While scrolling through a table with an activex preview of pdf on the side, you can go row by row down and activex will display content but not park on it.
Same program but with . Net:  It parks every time on the .net control. Behavior I do not want, it is only for display. Need to every time esc the control.

Can I alter this with some setting or another way ?
Thx
Sabrina

Met vriendelijke groet - With kind regards,

Sabrina Horst
Analist/programmeur
+31 (0)6 20303889

 


meilink.eu
Meilink Beheer Borculo B.V. • Kamerlingh Onnesstraat 1
7271 AZ  Borculo • Nederland • +31 (0)545 253525
KvK 08009803 • Our general terms and conditions apply • Disclaimer

 


Bereikbaar op maandag, woensdag en donderdag

 

Join main@magicu-l.groups.io to automatically receive all group messages.