Re: Travel-agent demo from magicweb.io


Rob Westland
 

Have you installded IIS before you installed XPA 4.7?

When Magic can find the IIS-server it automatically installs the rights paths in IIS.

what error do you get with:  http(s)://localhost/MagicScripts/MGrqisp.dll

a) it can't find the dll at all -> path setting in IIS is not correct

b) it can be found, but it wants to be downloaded -> the dll is not set as executable

c) it works


Rob

Op 8-2-2021 om 22:23 schreef Tom Worthen:

I am attempting to get this running but apparently I have a setting that is not correct. L

 

I have xpa 4.7 installed. I downloaded the application and have it running in background. I downloaded node.js and installed the Angular CLI. I have updated the server-config.json file but I think I don’t have the line correct for the requestor because it can’t find it. I have tried about 3 different ways of referencing it and none of them have worked. Can someone point me to what that setting should be?

 

I have tried setting it similar to what I would for a web page and it doesn’t find the dll. I have set it to the file somewhat directly and still it can’t find the dll.

 

So, my question is what should this line look like: “requestor”:”MagicScripts/MGrqispi.dll”,

 

I am sure that MGrqispi.dll is correct and probably what is before the colon is correct. So, what should I have in place of MagicScripts? My xpa installation is at c:\MSE\xpa47 with the scrips folder being in that folder and of course the dll is in the scripts folder. My entry in IIS for this is xpaScripts. The physical path for that is C:\MSE\xpa47\Scripts.

 

Hopefully someone can understand what I have put here and help me out. J

 

Thanks,

Tom

 

Join main@magicu-l.groups.io to automatically receive all group messages.