MagicXPA4.7.1 fails to build a Web Client application


Johan Vissenberg
 

Hi,

I installed MagicXPA4.71. on a fresh pc.
Then I tried to build the sample of the Magic Web SPA Tutorial.
Generate Web Application, and ending up with a cascade of errors.
See below.
How am I going to solve these errors?
There is no Help.....

Please advice
Regards
Johan Vissenberg



Generation output:
Generating new project
 
C:\Projects\mgSPA\SPA>echo off 
generating new project "SPA"
Install angular/cli@8 - Installing angular/cli version 8
 
added 261 packages, and audited 262 packages in 18s
 
30 packages are looking for funding
  run `npm fund` for details
 
3 low severity vulnerabilities
 
To address all issues (including breaking changes), run:
  npm audit fix --force
 
Run `npm audit` for details.
CREATE SPA/angular.json (3569 bytes)
CREATE SPA/package.json (1289 bytes)
CREATE SPA/README.md (1021 bytes)
CREATE SPA/tsconfig.json (543 bytes)
CREATE SPA/tslint.json (1953 bytes)
CREATE SPA/.editorconfig (246 bytes)
CREATE SPA/.gitignore (631 bytes)
CREATE SPA/browserslist (429 bytes)
CREATE SPA/karma.conf.js (1015 bytes)
CREATE SPA/tsconfig.app.json (270 bytes)
CREATE SPA/tsconfig.spec.json (270 bytes)
CREATE SPA/src/favicon.ico (948 bytes)
CREATE SPA/src/index.html (289 bytes)
CREATE SPA/src/main.ts (372 bytes)
CREATE SPA/src/polyfills.ts (2838 bytes)
CREATE SPA/src/styles.css (80 bytes)
CREATE SPA/src/test.ts (642 bytes)
CREATE SPA/src/assets/.gitkeep (0 bytes)
CREATE SPA/src/environments/environment.prod.ts (51 bytes)
CREATE SPA/src/environments/environment.ts (662 bytes)
CREATE SPA/src/app/app.module.ts (314 bytes)
CREATE SPA/src/app/app.component.html (25498 bytes)
CREATE SPA/src/app/app.component.spec.ts (972 bytes)
CREATE SPA/src/app/app.component.ts (207 bytes)
CREATE SPA/src/app/app.component.css (0 bytes)
CREATE SPA/e2e/protractor.conf.js (808 bytes)
CREATE SPA/e2e/tsconfig.json (214 bytes)
CREATE SPA/e2e/src/app.e2e-spec.ts (636 bytes)
CREATE SPA/e2e/src/app.po.ts (262 bytes)
adding Magic support`
[V-CLI] cmd.exe /c ng add @magic-xpa/cli@4.701.0 --project=SPA --skipHelp --angularVersion=4.701.0 --cliVersion=4.701.0
Installing packages for tooling via npm.
 
Generate Route Map
 
Generation warnings/errors:
A subdirectory or file C:\Projects\ngSPA already exists.
npm WARN deprecated ini@1.3.5: Please update to ini >=1.3.6 to avoid a prototype pollution issue
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
Your global Angular CLI version (11.2.4) is greater than your local version (8.3.29). The local Angular CLI version is used.
 
To disable this warning use "ng config -g cli.warnings.versionMismatch false".
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: spa@0.0.0
npm ERR! Found: jasmine-core@3.4.0
npm ERR! node_modules/jasmine-core
npm ERR!   dev jasmine-core@"~3.4.0" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer jasmine-core@">=3.5" from karma-jasmine-html-reporter@1.5.4
npm ERR! node_modules/karma-jasmine-html-reporter
npm ERR!   dev karma-jasmine-html-reporter@"^1.4.0" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR! 
npm ERR! See C:\Users\Administrator\AppData\Local\npm-cache\eresolve-report.txt for a full report.
 
npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Administrator\AppData\Local\npm-cache\_logs\2021-03-18T19_42_47_850Z-debug.log
Package install failed, see above.
Your global Angular CLI version (11.2.4) is greater than your local version (8.3.29). The local Angular CLI version is used.
 
To disable this warning use "ng config -g cli.warnings.versionMismatch false".
An unhandled exception occurred: npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: spa@0.0.0
npm ERR! Found: jasmine-core@3.4.0
npm ERR! node_modules/jasmine-core
npm ERR!   dev jasmine-core@"~3.4.0" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer jasmine-core@">=3.5" from karma-jasmine-html-reporter@1.5.4
npm ERR! node_modules/karma-jasmine-html-reporter
npm ERR!   dev karma-jasmine-html-reporter@"^1.4.0" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR! 
npm ERR! See C:\Users\Administrator\AppData\Local\npm-cache\eresolve-report.txt for a full report.
 
npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Administrator\AppData\Local\npm-cache\_logs\2021-03-18T19_42_55_152Z-debug.log
Package install failed, see above.
See "C:\Users\ADMINI~1\AppData\Local\Temp\ng-lWcQmk\angular-errors.log" for further details.
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: spa@0.0.0
npm ERR! Found: jasmine-core@3.4.0
npm ERR! node_modules/jasmine-core
npm ERR!   dev jasmine-core@"~3.4.0" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer jasmine-core@">=3.5" from karma-jasmine-html-reporter@1.5.4
npm ERR! node_modules/karma-jasmine-html-reporter
npm ERR!   dev karma-jasmine-html-reporter@"^1.4.0" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR! 
npm ERR! See C:\Users\Administrator\AppData\Local\npm-cache\eresolve-report.txt for a full report.
 
npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Administrator\AppData\Local\npm-cache\_logs\2021-03-18T19_42_57_734Z-debug.log
 
C:\Projects\ngSPA\SPA>echo off 
generating routes map
 
Generation warnings/errors:
Your global Angular CLI version (11.2.4) is greater than your local version (8.3.29). The local Angular CLI version is used.
 
To disable this warning use "ng config -g cli.warnings.versionMismatch false".
An unhandled exception occurred: Could not find module "@magic-xpa/cli" from "C:\\Projects\\ngSPA\\SPA".
See "C:\Users\ADMINI~1\AppData\Local\Temp\ng-sTz1rK\angular-errors.log" for further details.
 
 
 Generate Modules
 
C:\Projects\ngSPA\SPA>echo off 
copying files
 
 
 
C:\Projects\ngSPA\SPA>echo off 
generating modules
[V-CLI] cmd.exe /c ng g @magic-xpa/cli:modules
 
Generation warnings/errors:
Your global Angular CLI version (11.2.4) is greater than your local version (8.3.29). The local Angular CLI version is used.
 
To disable this warning use "ng config -g cli.warnings.versionMismatch false".
An unhandled exception occurred: Could not find module "@magic-xpa/cli" from "C:\\Projects\\ngSPA\\SPA".
See "C:\Users\ADMINI~1\AppData\Local\Temp\ng-w5u3xM\angular-errors.log" for further details.
 
Generate Components
 
C:\Projects\ngSPA\SPA>echo off 
copying files
 
 
 
C:\Projects\ngSPA\SPA>echo off 
generating components
[V-CLI] cmd.exe /c ng g @magic-xpa/cli:magic
 
Generation warnings/errors:
Your global Angular CLI version (11.2.4) is greater than your local version (8.3.29). The local Angular CLI version is used.
 
To disable this warning use "ng config -g cli.warnings.versionMismatch false".
An unhandled exception occurred: Could not find module "@magic-xpa/cli" from "C:\\Projects\\ngSPA\\SPA".
See "C:\Users\ADMINI~1\AppData\Local\Temp\ng-puiTGA\angular-errors.log" for further details.
 


 

Join main@magicu-l.groups.io to automatically receive all group messages.