TLS 1.2 on ClickOnce #ria #xpa


Darren
 

Hello Everyone,

Our application Supports TLS 1.2 but however for some reason, unless we force the client to add the registry key (SchUseStrongCrypto) like below, it won't use TLS 1.2 and we can't force our  4000+ clients/users to update their registry for it.

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\.NETFramework\v4.0.30319]
"SystemDefaultTlsVersions"=dword:00000001
"SchUseStrongCrypto"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]
"SystemDefaultTlsVersions"=dword:00000001
"SchUseStrongCrypto"=dword:00000001


However, using RIAModule desktop without clickonce works but we want to push it through Clickonce.

 

Regards,

Darren Jimenez

Join main@magicu-l.groups.io to automatically receive all group messages.