Date   

Re: Magic XPA 3.3 RIA MAGIC LICENSE PROBLEM #xpa #ria

Tom Worthen
 

Viktor,

 

I suspect your magic.ini’s you are using to run both applications has the line “MaxConcurrentUsers = 2”. Since you indicate you have a 2 user license when you start both applications you are telling the system you want 4 users. That is what mgstations is showing you. When you get into RIA it is not the number of engines you have running but the number of users you have set in the ini that is counted. That same thing is true for an html merge application. If you want both of them to run at the same time you will have to change that line to 1 instead of 2.

 

Hope that helps,

Tom

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of lehoczki.viktor via Groups.Io
Sent: Tuesday, November 19, 2019 8:52 AM
To: main@magicu-l.groups.io
Subject: [magicu-l] Magic XPA 3.3 RIA MAGIC LICENSE PROBLEM #xpa #ria

 

Dear Members,

There's a strange behaviour of the magic broker.

mgrb.ini:
...
[APPLICATIONS_LIST]
Teszt_PDA = MgxpaRuntime.exe /ApplicationPublicName = Teszt_PDA /[MAGIC_LOGICAL_NAMES]Dir = c:\SVN\MN_Ugyvitel\Teszt_Database\,c:\SVNXPA\XPA_PDA\,,,1,1
PDA = MgxpaRuntime.exe /ApplicationPublicName = PDA,c:\SVNXPA\XPA_PDA\,,,1,1
...

The difference between the 2 applications is the Dir directory.
These 2 are the same. PDA uses the production the Teszt_PDA uses the test environment data.
There's a 2 user RIA license.

1 application is running for both environment so currently there're 2 lines in broker monitor at the startup.
In some seconds the PDA line disappears and in the broker_activity.log license exceeded.row appears.
When I run mgstations.exe it says 2 application uses twice 2 license. So 4 users consumed.
Is anyone has experience with MGRIA license?
2 applications (MgxpaRuntime.exe) running with 2 license.not 4. Why there's license exceeded?
How to use the licenses not to have license exceeded error?

When I have only 1 line in mgrb.ini under [APPLICATIONS_LIST] it says 2 users consumed but only 1 MgxpaRuntime.exe is running.

Do we need 2 times 1 user intead of 1 time 2 user license?

Best regards,

Viktor


Magic XPA 3.3 RIA MAGIC LICENSE PROBLEM #xpa #ria

lehoczki@...
 

Dear Members,

There's a strange behaviour of the magic broker.

mgrb.ini:
...
[APPLICATIONS_LIST]
Teszt_PDA = MgxpaRuntime.exe /ApplicationPublicName = Teszt_PDA /[MAGIC_LOGICAL_NAMES]Dir = c:\SVN\MN_Ugyvitel\Teszt_Database\,c:\SVNXPA\XPA_PDA\,,,1,1
PDA = MgxpaRuntime.exe /ApplicationPublicName = PDA,c:\SVNXPA\XPA_PDA\,,,1,1
...

The difference between the 2 applications is the Dir directory.
These 2 are the same. PDA uses the production the Teszt_PDA uses the test environment data.
There's a 2 user RIA license.

1 application is running for both environment so currently there're 2 lines in broker monitor at the startup.
In some seconds the PDA line disappears and in the broker_activity.log license exceeded.row appears.
When I run mgstations.exe it says 2 application uses twice 2 license. So 4 users consumed.
Is anyone has experience with MGRIA license?
2 applications (MgxpaRuntime.exe) running with 2 license.not 4. Why there's license exceeded?
How to use the licenses not to have license exceeded error?

When I have only 1 line in mgrb.ini under [APPLICATIONS_LIST] it says 2 users consumed but only 1 MgxpaRuntime.exe is running.

Do we need 2 times 1 user intead of 1 time 2 user license?

Best regards,

Viktor


Re: PushOK SVN

Gábor Bor
 

Hy gusys,

Thank you for your answers. Our problem is solved by their webpage has fixed, but thank you for tips. :)

Best Regadrs,
Gábor


Re: PushOK SVN

Sabrina Horst
 

Bit late sorry

We used to use it and it worked fine until we had some issues.
Then we found out that there is no way you can get support.
Email , telephone - they don't respond.

Ultimately we got rid of it and chose subversion.

Op 11-11-2019 om 12:38 schreef Gábor Bor:

Hy Magicians, 

Does anyone use PushOK as verison control system? The webpage of provider doesn't work...


Re: Gigaspaces deployment issue #xpa

Andreas Sedlmeier
 

I never did anything with Gigaspaces or with Magic & Gigaspaces. When I look however in these screenshots: http://kb.magicsoftware.com/articles/bl_Reference/Space-Troubleshooting-xpi-46
Then I can see that the locator's listener is configured on 127.0.0.1:4174 and that wont work. You have to bind to the IP of that machine (192.168.10.85) or to *any* IP of that machine which is typically 0.0.0.0
127.0.0.1 will only work from localhost.

Telnet is not a proof here. Telnet connects to the machine and then request actually is from localhost

Maybe thats the issue

You could work with a reverse proxy to get access to 127.0.0.1:4174 from remote.
Traefik.io is nice and easy to configure (actually awesome). Supports TCP as well since v2.

Best regards,

Andreas


Re: Models

Pavel Mencl
 

Please ignore, momentary lapse of reason.
Pavel


Models

Pavel Mencl
 

xpa 3.1

I'd like to define a field model Numeric that would be N8.2 and N8.2C in GUI Display(s).
How would I do that?

Pavel


Gigaspaces deployment issue #xpa

Joseph Knickerbocker
 

Hello group, I'm currently having a blast tinkering with gigaspaces... Has anybody ever deployed gigaspaces and the MgWebRequester.dll on different servers? 

I have gigaspaces up and running with the MgWebRequester running locally, but when I try to go through the webrequester being hosted on an external IIS machine, I get the following error:

HTTP Error 500.0 - Can't find space jini://*/*/Magic_xpa_space?locators=192.168.10.85:4174

192.168.10.85:4174 is the proper address and port of the machine running the gigaspaces, and the port is open on telnet from the machine with the requester.

Any help would be very appreciated.

Thank you,
Joseph Knickerbocker 


Off topic: Oracle 11g cold backup

Todd Baremore
 

I have a new customer whose current solution is using Oracle 11g.  I was provide with a cold backup (2.36 GB total) of their data and NOTHING else.

I installed Oracle Express 11g on my laptop as well as Oracle SQL Developer 3.2.20.  I can connect to the XE instance and browse the tables provide by the installation.

My question:  Can I restore the cold backup I was given to the XE instance.  I created a new user and granted it every privilege I could find.   I am clueless about Oracle.  Any and all suggestions will be greatly appreciated. 

Thanks.

Todd


Re: Crash when doing search on variable list 3.2d

Gábor Bor
 

Hy Charles,

Good news, i'm live with it a half year ago, so... :D Do you know something about the estimated relase date? Is it possible in this year?

Best Regards,
Gábor


Re: Crash when doing search on variable list 3.2d

Mike Moore
 

MSE Support notified me this morning that this will be fixed in future version of Magic XPA 3.3g.




From:        "Heidi Schuppenhauer" <heidis13@...>
To:        main@magicu-l.groups.io
Date:        10/16/2019 09:54 AM
Subject:        Re: [magicu-l] Crash when doing search on variable list 3.2d
Sent by:        main@magicu-l.groups.io




"awesome bug"! Oxymoron of the week! :-)

No, I don't get that one. I also don't get the popup message you get.  

Looks like MSE is looking into the crashing issue though. Has anyone else had the same issue for copy and paste in the editor?



Heidi.Schuppenhauer

 

 


On Wed, Oct 16, 2019 at 12:46 PM Brenda Bullorini <bbullorini@...> wrote:

I have another awesome bug:
I can't use copy/paste (Ctrl+C, Ctrl+V) in the expression editor, unless I press F6 to open the expanded view.
Anyone else has this problem?





Re: Magic XPA 3.3 RIA deployment problem #xpa #ria

Tim Downie
 

You can start 10 engines on one broker if you want to , all servicing a different application....giveing you 10 icons on your android device. By having each with a different application name - this of course uses more licenses but is easy to setup
From: main@magicu-l.groups.io <main@magicu-l.groups.io> on behalf of lehoczki.viktor via Groups.Io <lehoczki.viktor@...>
Sent: Thursday, 14 November 2019 7:32:05 AM
To: main@magicu-l.groups.io <main@magicu-l.groups.io>
Subject: Re: [magicu-l] Magic XPA 3.3 RIA deployment problem #xpa #ria
 
Dear Andreas and Tim!

Thank you for your infos!
So, I have to do interface building as many times I need icon on my phone.
Yes, I want to do this because there're different applications for a company which runs on different servers.There's no possibility to use one magic broker. This is the same situation with testing and production environment.
Thank you very much!

Best regards,

Viktor


Re: Magic XPA 3.3 RIA deployment problem #xpa #ria

Andreas Sedlmeier
 

On Thu, Nov 14, 2019 at 08:32 AM, <lehoczki.viktor@...> wrote:
Thank you for your infos!
So, I have to do interface building as many times I need icon on my phone.
Yes, I want to do this because there're different applications for a company which runs on different servers.There's no possibility to use one magic broker. This is the same situation with testing and production environment.
Thank you very much!
If you have two different apps you have to run the Interface builder for each of this. Its different apps.

If you have ONE app which you want to deploy to multiple sites/environments you have to run the interface builder multiple times, and change settings there.

This is however error-prone, a lot of work and a never ending story

When you want to deploy an app to multiple environments (like you have to) you are much better off with a build pipline.

The Magic mousclick-based Interface building technology you can not change but once you did and the sources are generated you can run the build from script and exchange the configuration file to one which is needed for the environment you want to deploy to, This can be automated.

I would install me a gitlab to get git and gitlab-ci and deploy to Kubernetes which is nicely integrated there.
In Kubernetes you can separate your environments by namespaces and you can have as much as you want

Magic & Kubernetes is however a different issue ^^ https://www.nomadproject.io/ might fit better for Legacy applications.
I see if I can add what I described to XpaDemo . Its about deployment anyways.

Best regards,

Andreas









Re: Magic XPA 3.3 RIA deployment problem #xpa #ria

lehoczki@...
 

Dear Andreas and Tim!

Thank you for your infos!
So, I have to do interface building as many times I need icon on my phone.
Yes, I want to do this because there're different applications for a company which runs on different servers.There's no possibility to use one magic broker. This is the same situation with testing and production environment.
Thank you very much!

Best regards,

Viktor


Re: Magic XPA 3.3 RIA deployment problem #xpa #ria

Andreas Sedlmeier
 

On Wed, Nov 13, 2019 at 11:13 AM, Tim Downie wrote:
We just build the apk twice into two different published folders using the interface builder....you end up with two apks in two different virtual iis folders with two different sets of properties defined in the properties.txt file inside the published foler.
Ok, thanks for clarification, then it's clear. You in fact use the interface builder twice to create two different apks. "Publish apk twice" did sound to me as if you would use one apk for different environments.

Actually, in order to support as many environments as you want, you do not need to use the interface builder more then once because you can also start the build after replacing the configuration files or even change the configuration of the generated apk. At the end its a Java jar respectively a zipfile and actually it's a good idea to do it like that because then you can factor out errors during "interface building" and what you depoloy to production is actually what you did use in dev/test too.


Re: Magic XPA 3.3 RIA deployment problem #xpa #ria

Tim Downie
 

We just build the apk twice into two different published folders using the interface builder....you end up with two apks in two different virtual iis folders with two different sets of properties defined in the properties.txt file inside the published foler.
From: main@magicu-l.groups.io <main@magicu-l.groups.io> on behalf of Andreas Sedlmeier <sedlmeier@...>
Sent: Wednesday, 13 November 2019 8:15:46 AM
To: main@magicu-l.groups.io <main@magicu-l.groups.io>
Subject: Re: [magicu-l] Magic XPA 3.3 RIA deployment problem #xpa #ria
 

[Edited Message Follows]

On Tue, Nov 12, 2019 at 07:48 PM, Tim Downie wrote:
The only way i see right now is publish apk twice. Or as mamy times as you need - we do this for all our mobile apps - one for dev one for prod. This i dont see really as much of an issue
And how do you actually do this ? The configuration file contains information about the backend and that gets compiled into the apk during build process. So either you work with different application properties (which is in terms of Magic Interface Builder) different applications or you replace the configuration file before build - or after build in the apk, If you dont do and you initially specified your production environment as backend your dev apk will access production and vice versa. Do I miss something here ?? Im not really familiar with RIA deployments.

P.S./Ediit: Its following file which gets generated by the Interface builder and from where the builder (mostly powershell a little gradle) will read the configuration information from:
https://github.com/asedl/XpaDemo/blob/master/Components/XpaTMobile/PublishedApplication/Android/XpaTMobile.txt
That needs to be replaced (changed) before the actual build starts. Otherwise this information will end up in apk 

Correct ?

Andreas


Re: Magic XPA 3.3 RIA deployment problem #xpa #ria

Andreas Sedlmeier
 
Edited

On Tue, Nov 12, 2019 at 07:48 PM, Tim Downie wrote:
The only way i see right now is publish apk twice. Or as mamy times as you need - we do this for all our mobile apps - one for dev one for prod. This i dont see really as much of an issue
And how do you actually do this ? The configuration file contains information about the backend and that gets compiled into the apk during build process. So either you work with different application properties (which is in terms of Magic Interface Builder) different applications or you replace the configuration file before build - or after build in the apk, If you dont do and you initially specified your production environment as backend your dev apk will access production and vice versa. Do I miss something here ?? Im not really familiar with RIA deployments.

P.S./Ediit: Its following file which gets generated by the Interface builder and from where the builder (mostly powershell a little gradle) will read the configuration information from:
https://github.com/asedl/XpaDemo/blob/master/Components/XpaTMobile/PublishedApplication/Android/XpaTMobile.txt
That needs to be replaced (changed) before the actual build starts. Otherwise this information will end up in apk 

Correct ?

Andreas


Re: Video and Audio

Tim Downie
 

I have not done this but this should work


Embedding the Windows Media Player Control in a C# Solution. 05/31/2018; 2 minutes to read; In this article. To use the functionality of Windows Media Player in a C# application, first add the component to a form as described in Using the Windows Media Player Control with Microsoft Visual Studio. The following sections describe how to create an application that plays video and uses custom play ...
docs.microsoft.com




From: main@magicu-l.groups.io <main@magicu-l.groups.io> on behalf of melaicute_0115 via Groups.Io <melaicute_0115@...>
Sent: Wednesday, 13 November 2019 1:40 AM
To: main@magicu-l.groups.io <main@magicu-l.groups.io>
Subject: Re: [magicu-l] Video and Audio
 
hi sir govert, im only doing a windows based program. is there any other way sir?


Re: Video and Audio

melaicute_0115@...
 

hi sir govert, im only doing a windows based program. is there any other way sir?


Re: Magic XPA 3.3 RIA deployment problem #xpa #ria

Tim Downie
 

The only way i see right now is publish apk twice. Or as mamy times as you need - we do this for all our mobile apps - one for dev one for prod. This i dont see really as much of an issue
From: main@magicu-l.groups.io <main@magicu-l.groups.io> on behalf of Andreas Sedlmeier <sedlmeier@...>
Sent: Tuesday, 12 November 2019 11:46:31 AM
To: main@magicu-l.groups.io <main@magicu-l.groups.io>
Subject: Re: [magicu-l] Magic XPA 3.3 RIA deployment problem #xpa #ria
 
On Tue, Nov 12, 2019 at 10:46 AM, Tim Downie wrote:
Im not really aure why you would want to do this have the same install twice but pointing to different servers?
Thats the whole point of CI/CD. The application I currently work on which is Angular on frontend and Java on backend is I think deployed to 20 or 30 different environments (for testing, feature branches, integration, whatever). Only production environment there's just one. That however is a cluster. Kubernetes actually.

It's however not what Victor wants as far as I understand it. He wants two different icons on his mobile device (Android) pointing to two different applications and for that you just have to create two Magic (RIA) applications. Server settings and such would be (could be) identical, it's only the appName which needs to differ because thats what the requester will use in order to find an application server (by asking the broker).

Since its the interface builder which generates the required Java sources it's not possible to build any Magic RIA application without and if there's a change where you are not absolutely sure that it has no impact on the client side, you need to run the Interface builder again. A way to automate this there's none as far as I know . There's however some promises from MSE to come up with a version which fits better in modern DevOps / GitOps - automated delivery pipelines, ... 

Best regards,

Andreas

4301 - 4320 of 195858