Date   

Re: Get.dll instructions

sherman levine
 

Sent you the help file

Sherm


On 12/23/2019 08:28 AM, John Knickerbocker wrote:
Anyone have the parameters to pass get.dl for the week function?

Thanks,




Sent with Gmelius


Get.dll instructions

John Knickerbocker
 

Anyone have the parameters to pass get.dl for the week function?

Thanks,




Sent with Gmelius


Re: App in Magic XPA or other tool

Freddy Dewulf
 

Govert, Tim, Todd,

Thanks for the advice and comments.
I'll go through the documentation and do the necassary.
First of all, I will contact MSE to inform myself about the license to use and the price.
And then, our customer must agree.

Thanks
Freddy Dewulf


Re: Document Type WS

Jackson, Adam
 

HI Brenda,

 

That worked – thank you!

 

Regards

 

Adam

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Brenda Bullorini
Sent: 20 December 2019 14:59
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Document Type WS

 

This should work with invoke ws lite...

<?xml version="1.0" encoding="UTF-8" standalone="no" ? >

 <tem:request>

<mtp:Jobs>

   <mtp1:Job>

  <mtp1:JobNumber>5</mtp1:JobNumber>

  <mtp1:Weight>10.5</mtp1:Weight>

  <mtp1:Cube>2.75</mtp1:Cube>

  <mtp1:Duration>PT5M</mtp1:Duration>

  <mtp1:Revenue>10</mtp1:Revenue>

  <mtp1:JobTypes>type1</mtp1:JobTypes>

  <mtp1:Skills>TL</mtp1:Skills>

  <mtp1:CompanyName>TAP V3</mtp1:CompanyName>

  <mtp1:CompanyPostcode>EH54 5NS</mtp1:CompanyPostcode>

  <mtp1:CompanyAddressLine1>The Green Dragon Hotel</mtp1:CompanyAddressLine1>

  <mtp1:CompanyAddressLine2></mtp1:CompanyAddressLine2>

  <mtp1:CompanyCity>Hereford</mtp1:CompanyCity>

  <mtp1:Notes>lorem ipsum</mtp1:Notes>

   </mtp1:Job>

</mtp:Jobs>

 </tem:request>

</tem:Import>


Re: Document Type WS

Jackson, Adam
 

Hi Andreas,

 

When I send the shortened payload below I get “Unexpected return Content-Type: application/json” error. I only want to use xpa if I can and preferably WS Lite to minimise proliferation of other software. I’m not a programmer and don’t want to get involved with other software if at all possible.

 

Thanks for help so far, regards,

 

Adam

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Andreas Sedlmeier
Sent: 20 December 2019 18:34
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Document Type WS

 

Hi Adam,

On Fri, Dec 20, 2019 at 01:12 PM, Jackson, Adam wrote:

Start element 'Import' from namespace 'http://tempuri.org/' expected. Found element 'soapenv:Envelope'

That error message makes it quite clear. Look into the parameters of your WS Lite operation and probably you''ll see one there, Type: xsd:Sting or "Blob".
We could telly you exactly when you share the WSDL which you did use to create that WS client.

I suppose you are fine if you write following to a Blob variable (Type: Unicode) and use that variable as a parameter:

<tem:Import>

         <tem:request>

            <mtp:Jobs>

               <mtp1:Job>

                  <mtp1:JobNumber>5</mtp1:JobNumber>

                  <mtp1:Weight>10.5</mtp1:Weight>

                  <mtp1:Cube>2.75</mtp1:Cube>

                  <mtp1:Duration>PT5M</mtp1:Duration>

                  <mtp1:Revenue>10</mtp1:Revenue>

                  <mtp1:JobTypes>type1</mtp1:JobTypes>

                  <mtp1:Skills>TL</mtp1:Skills>

                  <mtp1:CompanyName>TAP V3</mtp1:CompanyName>

                  <mtp1:CompanyPostcode>EH54 5NS</mtp1:CompanyPostcode>

                  <mtp1:CompanyAddressLine1>The Green Dragon Hotel</mtp1:CompanyAddressLine1>

                  <mtp1:CompanyAddressLine2></mtp1:CompanyAddressLine2>

                  <mtp1:CompanyCity>Hereford</mtp1:CompanyCity>

                  <mtp1:Notes>lorem ipsum</mtp1:Notes>

               </mtp1:Job>

            </mtp:Jobs>

            <mtp:UserName>mark.whelan@...</mtp:UserName>

         </tem:request>

      </tem:Import>

Now Magic will find what it expects at position 1: "<tem:Import>" (and no longer "<soapenv:")
Your WS client operation will look similar to this one:



By coincidence I do work since yesterday on good old SOAP clients too for Dun & Bradstreet connectivity.
Im quite happy that I do not have to use Magic for this ^^. Magic & SOAP is a bit of a nightmare.

Try to get things work with SOAP UI first. And then think about using the code which it generates for you automatically.
Alternative: Use CURL or so do send your SOAP request to somewhere. That will result in far less issues.

Best regards,

Andreas


Re: How to get eDeveloper Service Pack 8 update?

Danica Majernikova
 

Hi,
you need SP 10. You approach Magic Software company, they provide you with the link.


From: main@magicu-l.groups.io <main@magicu-l.groups.io> on behalf of elitenet2002 via Groups.Io <elitenet2002@...>
Sent: December 22, 2019 7:22 AM
To: main@magicu-l.groups.io <main@magicu-l.groups.io>
Subject: [magicu-l] How to get eDeveloper Service Pack 8 update?
 
HI,
I work with eDeveloper v9.4SP5 long time ago. I wanna try again to make some business with him.

I hear that if I need to migrate applications from eDeveloper 9.4SP7 to Xpa I need first to migrate to uniPaaS V1.0...but I need service pack min ver 7...where I can download Service pack 7 or 8?


How to get eDeveloper Service Pack 8 update?

elitenet2002@...
 

HI,
I work with eDeveloper v9.4SP5 long time ago. I wanna try again to make some business with him.

I hear that if I need to migrate applications from eDeveloper 9.4SP7 to Xpa I need first to migrate to uniPaaS V1.0...but I need service pack min ver 7...where I can download Service pack 7 or 8?


Re: Outlook called from 8.30 (att Johan Vissenberg, and/or others...)

Jacques
 

Hi Johan,
thanks for your answer, and sorry for the delay.... I've been in the hospital for a small surgery problem :(:(
I did the 2 modifications proposed, and still the same problem :
Loading the object gives me an error 10, and after that it takes minutes to come back, as if hanging somewhere....
any clue very welcome...
Best wishes for your health, Merry Xmas and Happy NewYear
Jacques


Re: Document Type WS

Andreas Sedlmeier
 

Hi Adam,

On Fri, Dec 20, 2019 at 01:12 PM, Jackson, Adam wrote:
Start element 'Import' from namespace 'http://tempuri.org/' expected. Found element 'soapenv:Envelope'
That error message makes it quite clear. Look into the parameters of your WS Lite operation and probably you''ll see one there, Type: xsd:Sting or "Blob".
We could telly you exactly when you share the WSDL which you did use to create that WS client.

I suppose you are fine if you write following to a Blob variable (Type: Unicode) and use that variable as a parameter:

<tem:Import>

         <tem:request>

            <mtp:Jobs>

               <mtp1:Job>

                  <mtp1:JobNumber>5</mtp1:JobNumber>

                  <mtp1:Weight>10.5</mtp1:Weight>

                  <mtp1:Cube>2.75</mtp1:Cube>

                  <mtp1:Duration>PT5M</mtp1:Duration>

                  <mtp1:Revenue>10</mtp1:Revenue>

                  <mtp1:JobTypes>type1</mtp1:JobTypes>

                  <mtp1:Skills>TL</mtp1:Skills>

                  <mtp1:CompanyName>TAP V3</mtp1:CompanyName>

                  <mtp1:CompanyPostcode>EH54 5NS</mtp1:CompanyPostcode>

                  <mtp1:CompanyAddressLine1>The Green Dragon Hotel</mtp1:CompanyAddressLine1>

                  <mtp1:CompanyAddressLine2></mtp1:CompanyAddressLine2>

                  <mtp1:CompanyCity>Hereford</mtp1:CompanyCity>

                  <mtp1:Notes>lorem ipsum</mtp1:Notes>

               </mtp1:Job>

            </mtp:Jobs>

            <mtp:UserName>mark.whelan@...</mtp:UserName>

         </tem:request>

      </tem:Import>

Now Magic will find what it expects at position 1: "
<tem:Import>" (and no longer "<soapenv:")
Your WS client operation will look similar to this one:



By coincidence I do work since yesterday on good old SOAP clients too for Dun & Bradstreet connectivity.
Im quite happy that I do not have to use Magic for this ^^. Magic & SOAP is a bit of a nightmare.

Try to get things work with SOAP UI first. And then think about using the code which it generates for you automatically.
Alternative: Use CURL or so do send your SOAP request to somewhere. That will result in far less issues.

Best regards,

Andreas



Re: Document Type WS

Brenda Bullorini
 

This should work with invoke ws lite...

<?xml version="1.0" encoding="UTF-8" standalone="no" ? >
 <tem:request>
<mtp:Jobs>
   <mtp1:Job>
  <mtp1:JobNumber>5</mtp1:JobNumber>
  <mtp1:Weight>10.5</mtp1:Weight>
  <mtp1:Cube>2.75</mtp1:Cube>
  <mtp1:Duration>PT5M</mtp1:Duration>
  <mtp1:Revenue>10</mtp1:Revenue>
  <mtp1:JobTypes>type1</mtp1:JobTypes>
  <mtp1:Skills>TL</mtp1:Skills>
  <mtp1:CompanyName>TAP V3</mtp1:CompanyName>
  <mtp1:CompanyPostcode>EH54 5NS</mtp1:CompanyPostcode>
  <mtp1:CompanyAddressLine1>The Green Dragon Hotel</mtp1:CompanyAddressLine1>
  <mtp1:CompanyAddressLine2></mtp1:CompanyAddressLine2>
  <mtp1:CompanyCity>Hereford</mtp1:CompanyCity>
  <mtp1:Notes>lorem ipsum</mtp1:Notes>
   </mtp1:Job>
</mtp:Jobs>
<mtp:UserName>mark.whelan@...</mtp:UserName>
 </tem:request>
</tem:Import>


Re: Document Type WS

Govert Schipper
 

Adam,

Are you using a blob to hold the xml message to pass as the body of the HTTP Post command?
Maybe convert it to UTF8 first using UTF8fromAnsi().


Van: main@magicu-l.groups.io <main@magicu-l.groups.io> namens Jackson, Adam <adam.jackson@...>
Verzonden: vrijdag 20 december 2019 14:00
Aan: main@magicu-l.groups.io <main@magicu-l.groups.io>; magicu-l@groups.io <magicu-l@groups.io>
Onderwerp: Re: [magicu-l] Document Type WS
 

HI,

 

HTTPPost looking better but not right. I get:

 

<?xml version="1.0" encoding="utf-8"?><s:Envelope xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><s:Fault><faultcode>s:Client</faultcode><faultstring>Unexpected end of file. Following elements are not closed: UserName, request, Import, Body, Envelope. Line 1, position 337.</faultstring></s:Fault></s:Body></s:Envelope>

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Govert Schipper
Sent: 20 December 2019 12:39
To: main@magicu-l.groups.io; magicu-l@groups.io
Subject: Re: [magicu-l] Document Type WS

 

Adam,

 

Have you tried using HTTP Post instead of Invoke WS Lite?

You will probably have to put back all the stripped soap tags.

 

Govert

 


Van: main@magicu-l.groups.io <main@magicu-l.groups.io> namens Jackson, Adam <adam.jackson@...>
Verzonden: vrijdag 20 december 2019 13:32
Aan: main@magicu-l.groups.io <main@magicu-l.groups.io>; magicu-l@groups.io <magicu-l@groups.io>
Onderwerp: Re: [magicu-l] Document Type WS

 

Govert,

 

Thanks for coming back so quickly. If I strip of those tags and xml tag I get similar error message and if do same but without adding xml tag get “Unexpected return Content-Type: application/json”

 

Adam

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Govert Schipper
Sent: 20 December 2019 12:21
To: magicu-l@groups.io; main@magicu-l.groups.io
Subject: Re: [magicu-l] Document Type WS

 

Hi Adam,

 

I think you have to strip the soap Envelop, Header and Body tags and start with the Import tag. Maybe you have to add the XML declaration before that.

 

Govert

 


Van: main@magicu-l.groups.io <main@magicu-l.groups.io> namens Jackson, Adam <adam.jackson@...>
Verzonden: vrijdag 20 december 2019 13:11
Aan: magicu-l@groups.io <magicu-l@groups.io>
Onderwerp: [magicu-l] Document Type WS

 

Hi,

 

I am struggling to get a Document type WS working using Invoke WS Lite. I have only used RPC types before so unsure of the details of what I need to do. The payload I am trying to send is below. I got the endpoint working fine and it specified one parameter. I am sending the payload below as a variable type parameter. I have tried to send as an expression parameter but get same result. I am using a logical virtual as Success Indicator and text virtual as Error message. The error message I get returned is “Start element 'Import' from namespace 'http://tempuri.org/' expected. Found element 'soapenv:Envelope' from namespace 'http://schemas.xmlsoap.org/soap/envelope/'. Line 1, position 377.”.   Any clues anyone can give would be appreciated . xpa 2.5d

 

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:tem="http://tempuri.org/" xmlns:mtp="http://schemas.datacontract.org/2004/07/MTP.Api.WebServices.JobsImport.Contract" xmlns:mtp1="http://schemas.datacontract.org/2004/07/MTP.Api.WebServices.Contracts">

   <soapenv:Header/>

   <soapenv:Body>

      <tem:Import>

         <tem:request>

            <mtp:Jobs>

               <mtp1:Job>

                  <mtp1:JobNumber>5</mtp1:JobNumber>

                  <mtp1:Weight>10.5</mtp1:Weight>

                  <mtp1:Cube>2.75</mtp1:Cube>

                  <mtp1:Duration>PT5M</mtp1:Duration>

                  <mtp1:Revenue>10</mtp1:Revenue>

                  <mtp1:JobTypes>type1</mtp1:JobTypes>

                  <mtp1:Skills>TL</mtp1:Skills>

                  <mtp1:CompanyName>TAP V3</mtp1:CompanyName>

                  <mtp1:CompanyPostcode>EH54 5NS</mtp1:CompanyPostcode>

                  <mtp1:CompanyAddressLine1>The Green Dragon Hotel</mtp1:CompanyAddressLine1>

                  <mtp1:CompanyAddressLine2></mtp1:CompanyAddressLine2>

                  <mtp1:CompanyCity>Hereford</mtp1:CompanyCity>

                  <mtp1:Notes>lorem ipsum</mtp1:Notes>

               </mtp1:Job>

            </mtp:Jobs>

            <mtp:UserName>mark.whelan@...</mtp:UserName>

         </tem:request>

      </tem:Import>

   </soapenv:Body>

</soapenv:Envelope>

 


Re: Document Type WS

Jackson, Adam
 

HI,

 

HTTPPost looking better but not right. I get:

 

<?xml version="1.0" encoding="utf-8"?><s:Envelope xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body><s:Fault><faultcode>s:Client</faultcode><faultstring>Unexpected end of file. Following elements are not closed: UserName, request, Import, Body, Envelope. Line 1, position 337.</faultstring></s:Fault></s:Body></s:Envelope>

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Govert Schipper
Sent: 20 December 2019 12:39
To: main@magicu-l.groups.io; magicu-l@groups.io
Subject: Re: [magicu-l] Document Type WS

 

Adam,

 

Have you tried using HTTP Post instead of Invoke WS Lite?

You will probably have to put back all the stripped soap tags.

 

Govert

 


Van: main@magicu-l.groups.io <main@magicu-l.groups.io> namens Jackson, Adam <adam.jackson@...>
Verzonden: vrijdag 20 december 2019 13:32
Aan: main@magicu-l.groups.io <main@magicu-l.groups.io>; magicu-l@groups.io <magicu-l@groups.io>
Onderwerp: Re: [magicu-l] Document Type WS

 

Govert,

 

Thanks for coming back so quickly. If I strip of those tags and xml tag I get similar error message and if do same but without adding xml tag get “Unexpected return Content-Type: application/json”

 

Adam

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Govert Schipper
Sent: 20 December 2019 12:21
To: magicu-l@groups.io; main@magicu-l.groups.io
Subject: Re: [magicu-l] Document Type WS

 

Hi Adam,

 

I think you have to strip the soap Envelop, Header and Body tags and start with the Import tag. Maybe you have to add the XML declaration before that.

 

Govert

 


Van: main@magicu-l.groups.io <main@magicu-l.groups.io> namens Jackson, Adam <adam.jackson@...>
Verzonden: vrijdag 20 december 2019 13:11
Aan: magicu-l@groups.io <magicu-l@groups.io>
Onderwerp: [magicu-l] Document Type WS

 

Hi,

 

I am struggling to get a Document type WS working using Invoke WS Lite. I have only used RPC types before so unsure of the details of what I need to do. The payload I am trying to send is below. I got the endpoint working fine and it specified one parameter. I am sending the payload below as a variable type parameter. I have tried to send as an expression parameter but get same result. I am using a logical virtual as Success Indicator and text virtual as Error message. The error message I get returned is “Start element 'Import' from namespace 'http://tempuri.org/' expected. Found element 'soapenv:Envelope' from namespace 'http://schemas.xmlsoap.org/soap/envelope/'. Line 1, position 377.”.   Any clues anyone can give would be appreciated . xpa 2.5d

 

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:tem="http://tempuri.org/" xmlns:mtp="http://schemas.datacontract.org/2004/07/MTP.Api.WebServices.JobsImport.Contract" xmlns:mtp1="http://schemas.datacontract.org/2004/07/MTP.Api.WebServices.Contracts">

   <soapenv:Header/>

   <soapenv:Body>

      <tem:Import>

         <tem:request>

            <mtp:Jobs>

               <mtp1:Job>

                  <mtp1:JobNumber>5</mtp1:JobNumber>

                  <mtp1:Weight>10.5</mtp1:Weight>

                  <mtp1:Cube>2.75</mtp1:Cube>

                  <mtp1:Duration>PT5M</mtp1:Duration>

                  <mtp1:Revenue>10</mtp1:Revenue>

                  <mtp1:JobTypes>type1</mtp1:JobTypes>

                  <mtp1:Skills>TL</mtp1:Skills>

                  <mtp1:CompanyName>TAP V3</mtp1:CompanyName>

                  <mtp1:CompanyPostcode>EH54 5NS</mtp1:CompanyPostcode>

                  <mtp1:CompanyAddressLine1>The Green Dragon Hotel</mtp1:CompanyAddressLine1>

                  <mtp1:CompanyAddressLine2></mtp1:CompanyAddressLine2>

                  <mtp1:CompanyCity>Hereford</mtp1:CompanyCity>

                  <mtp1:Notes>lorem ipsum</mtp1:Notes>

               </mtp1:Job>

            </mtp:Jobs>

            <mtp:UserName>mark.whelan@...</mtp:UserName>

         </tem:request>

      </tem:Import>

   </soapenv:Body>

</soapenv:Envelope>

 


Re: Document Type WS

Brenda Bullorini
 

Try this:

<?xml version="1.0" encoding="UTF-8" standalone="no" ? >
<tem:Import xmlns:tem="http://tempuri.org/" xmlns:mtp="http://schemas.datacontract.org/2004/07/MTP.Api.WebServices.JobsImport.Contract" xmlns:mtp1="http://schemas.datacontract.org/2004/07/MTP.Api.WebServices.Contracts">
 <tem:request>
<mtp:Jobs>
   <mtp1:Job>
  <mtp1:JobNumber>5</mtp1:JobNumber>
  <mtp1:Weight>10.5</mtp1:Weight>
  <mtp1:Cube>2.75</mtp1:Cube>
  <mtp1:Duration>PT5M</mtp1:Duration>
  <mtp1:Revenue>10</mtp1:Revenue>
  <mtp1:JobTypes>type1</mtp1:JobTypes>
  <mtp1:Skills>TL</mtp1:Skills>
  <mtp1:CompanyName>TAP V3</mtp1:CompanyName>
  <mtp1:CompanyPostcode>EH54 5NS</mtp1:CompanyPostcode>
  <mtp1:CompanyAddressLine1>The Green Dragon Hotel</mtp1:CompanyAddressLine1>
  <mtp1:CompanyAddressLine2></mtp1:CompanyAddressLine2>
  <mtp1:CompanyCity>Hereford</mtp1:CompanyCity>
  <mtp1:Notes>lorem ipsum</mtp1:Notes>
   </mtp1:Job>
</mtp:Jobs>
<mtp:UserName>mark.whelan@...</mtp:UserName>
 </tem:request>
</tem:Import>


Re: Document Type WS

Jackson, Adam
 

I get:

 

Start element 'Import' from namespace 'http://tempuri.org/' expected. Found element 'Import' from namespace ''. Line 1, position 102.

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Brenda Bullorini
Sent: 20 December 2019 12:44
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Document Type WS

 

What if you send this:

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>

<Import>

 <request>

<Jobs>

   <Job>

  <JobNumber>5</JobNumber>

  <Weight>10.5</Weight>

  <Cube>2.75</Cube>

  <Duration>PT5M</Duration>

  <Revenue>10</Revenue>

  <JobTypes>type1</JobTypes>

  <Skills>TL</Skills>

  <CompanyName>TAP V3</CompanyName>

  <CompanyPostcode>EH54 5NS</CompanyPostcode>

  <CompanyAddressLine1>The Green Dragon Hotel</CompanyAddressLine1>

  <CompanyAddressLine2></CompanyAddressLine2>

  <CompanyCity>Hereford</CompanyCity>

  <Notes>lorem ipsum</Notes>

   </Job>

</Jobs>

 </request>

</Import>


Re: Document Type WS

Brenda Bullorini
 

What if you send this:

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<Import>
 <request>
<Jobs>
   <Job>
  <JobNumber>5</JobNumber>
  <Weight>10.5</Weight>
  <Cube>2.75</Cube>
  <Duration>PT5M</Duration>
  <Revenue>10</Revenue>
  <JobTypes>type1</JobTypes>
  <Skills>TL</Skills>
  <CompanyName>TAP V3</CompanyName>
  <CompanyPostcode>EH54 5NS</CompanyPostcode>
  <CompanyAddressLine1>The Green Dragon Hotel</CompanyAddressLine1>
  <CompanyAddressLine2></CompanyAddressLine2>
  <CompanyCity>Hereford</CompanyCity>
  <Notes>lorem ipsum</Notes>
   </Job>
</Jobs>
<UserName>mark.whelan@...</UserName>
 </request>
</Import>


Re: WinMaximize () - uniPaas 1.9g

JK Heydt
 

Wes, 

I set the Window Type to "Fit to MDI" and it works, but checker throws the following error: 

P0090: 'Invalid Window Type for a concurrent program.'...

I removed the placement settings so that doesn't fix the error. Can I just live with the error or is there another way to accomplish this?

Thanks
JK


Re: Document Type WS

Govert Schipper
 

Adam,

Have you tried using HTTP Post instead of Invoke WS Lite?
You will probably have to put back all the stripped soap tags.

Govert


Van: main@magicu-l.groups.io <main@magicu-l.groups.io> namens Jackson, Adam <adam.jackson@...>
Verzonden: vrijdag 20 december 2019 13:32
Aan: main@magicu-l.groups.io <main@magicu-l.groups.io>; magicu-l@groups.io <magicu-l@groups.io>
Onderwerp: Re: [magicu-l] Document Type WS
 

Govert,

 

Thanks for coming back so quickly. If I strip of those tags and xml tag I get similar error message and if do same but without adding xml tag get “Unexpected return Content-Type: application/json”

 

Adam

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Govert Schipper
Sent: 20 December 2019 12:21
To: magicu-l@groups.io; main@magicu-l.groups.io
Subject: Re: [magicu-l] Document Type WS

 

Hi Adam,

 

I think you have to strip the soap Envelop, Header and Body tags and start with the Import tag. Maybe you have to add the XML declaration before that.

 

Govert

 


Van: main@magicu-l.groups.io <main@magicu-l.groups.io> namens Jackson, Adam <adam.jackson@...>
Verzonden: vrijdag 20 december 2019 13:11
Aan: magicu-l@groups.io <magicu-l@groups.io>
Onderwerp: [magicu-l] Document Type WS

 

Hi,

 

I am struggling to get a Document type WS working using Invoke WS Lite. I have only used RPC types before so unsure of the details of what I need to do. The payload I am trying to send is below. I got the endpoint working fine and it specified one parameter. I am sending the payload below as a variable type parameter. I have tried to send as an expression parameter but get same result. I am using a logical virtual as Success Indicator and text virtual as Error message. The error message I get returned is “Start element 'Import' from namespace 'http://tempuri.org/' expected. Found element 'soapenv:Envelope' from namespace 'http://schemas.xmlsoap.org/soap/envelope/'. Line 1, position 377.”.   Any clues anyone can give would be appreciated . xpa 2.5d

 

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:tem="http://tempuri.org/" xmlns:mtp="http://schemas.datacontract.org/2004/07/MTP.Api.WebServices.JobsImport.Contract" xmlns:mtp1="http://schemas.datacontract.org/2004/07/MTP.Api.WebServices.Contracts">

   <soapenv:Header/>

   <soapenv:Body>

      <tem:Import>

         <tem:request>

            <mtp:Jobs>

               <mtp1:Job>

                  <mtp1:JobNumber>5</mtp1:JobNumber>

                  <mtp1:Weight>10.5</mtp1:Weight>

                  <mtp1:Cube>2.75</mtp1:Cube>

                  <mtp1:Duration>PT5M</mtp1:Duration>

                  <mtp1:Revenue>10</mtp1:Revenue>

                  <mtp1:JobTypes>type1</mtp1:JobTypes>

                  <mtp1:Skills>TL</mtp1:Skills>

                  <mtp1:CompanyName>TAP V3</mtp1:CompanyName>

                  <mtp1:CompanyPostcode>EH54 5NS</mtp1:CompanyPostcode>

                  <mtp1:CompanyAddressLine1>The Green Dragon Hotel</mtp1:CompanyAddressLine1>

                  <mtp1:CompanyAddressLine2></mtp1:CompanyAddressLine2>

                  <mtp1:CompanyCity>Hereford</mtp1:CompanyCity>

                  <mtp1:Notes>lorem ipsum</mtp1:Notes>

               </mtp1:Job>

            </mtp:Jobs>

            <mtp:UserName>mark.whelan@...</mtp:UserName>

         </tem:request>

      </tem:Import>

   </soapenv:Body>

</soapenv:Envelope>

 


Re: Document Type WS

Jackson, Adam
 

Govert,

 

Thanks for coming back so quickly. If I strip of those tags and xml tag I get similar error message and if do same but without adding xml tag get “Unexpected return Content-Type: application/json”

 

Adam

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Govert Schipper
Sent: 20 December 2019 12:21
To: magicu-l@groups.io; main@magicu-l.groups.io
Subject: Re: [magicu-l] Document Type WS

 

Hi Adam,

 

I think you have to strip the soap Envelop, Header and Body tags and start with the Import tag. Maybe you have to add the XML declaration before that.

 

Govert

 


Van: main@magicu-l.groups.io <main@magicu-l.groups.io> namens Jackson, Adam <adam.jackson@...>
Verzonden: vrijdag 20 december 2019 13:11
Aan: magicu-l@groups.io <magicu-l@groups.io>
Onderwerp: [magicu-l] Document Type WS

 

Hi,

 

I am struggling to get a Document type WS working using Invoke WS Lite. I have only used RPC types before so unsure of the details of what I need to do. The payload I am trying to send is below. I got the endpoint working fine and it specified one parameter. I am sending the payload below as a variable type parameter. I have tried to send as an expression parameter but get same result. I am using a logical virtual as Success Indicator and text virtual as Error message. The error message I get returned is “Start element 'Import' from namespace 'http://tempuri.org/' expected. Found element 'soapenv:Envelope' from namespace 'http://schemas.xmlsoap.org/soap/envelope/'. Line 1, position 377.”.   Any clues anyone can give would be appreciated . xpa 2.5d

 

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:tem="http://tempuri.org/" xmlns:mtp="http://schemas.datacontract.org/2004/07/MTP.Api.WebServices.JobsImport.Contract" xmlns:mtp1="http://schemas.datacontract.org/2004/07/MTP.Api.WebServices.Contracts">

   <soapenv:Header/>

   <soapenv:Body>

      <tem:Import>

         <tem:request>

            <mtp:Jobs>

               <mtp1:Job>

                  <mtp1:JobNumber>5</mtp1:JobNumber>

                  <mtp1:Weight>10.5</mtp1:Weight>

                  <mtp1:Cube>2.75</mtp1:Cube>

                  <mtp1:Duration>PT5M</mtp1:Duration>

                  <mtp1:Revenue>10</mtp1:Revenue>

                  <mtp1:JobTypes>type1</mtp1:JobTypes>

                  <mtp1:Skills>TL</mtp1:Skills>

                  <mtp1:CompanyName>TAP V3</mtp1:CompanyName>

                  <mtp1:CompanyPostcode>EH54 5NS</mtp1:CompanyPostcode>

                  <mtp1:CompanyAddressLine1>The Green Dragon Hotel</mtp1:CompanyAddressLine1>

                  <mtp1:CompanyAddressLine2></mtp1:CompanyAddressLine2>

                  <mtp1:CompanyCity>Hereford</mtp1:CompanyCity>

                  <mtp1:Notes>lorem ipsum</mtp1:Notes>

               </mtp1:Job>

            </mtp:Jobs>

            <mtp:UserName>mark.whelan@...</mtp:UserName>

         </tem:request>

      </tem:Import>

   </soapenv:Body>

</soapenv:Envelope>

 


Re: Document Type WS

Govert Schipper
 

Hi Adam,

I think you have to strip the soap Envelop, Header and Body tags and start with the Import tag. Maybe you have to add the XML declaration before that.

Govert


Van: main@magicu-l.groups.io <main@magicu-l.groups.io> namens Jackson, Adam <adam.jackson@...>
Verzonden: vrijdag 20 december 2019 13:11
Aan: magicu-l@groups.io <magicu-l@groups.io>
Onderwerp: [magicu-l] Document Type WS
 

Hi,

 

I am struggling to get a Document type WS working using Invoke WS Lite. I have only used RPC types before so unsure of the details of what I need to do. The payload I am trying to send is below. I got the endpoint working fine and it specified one parameter. I am sending the payload below as a variable type parameter. I have tried to send as an expression parameter but get same result. I am using a logical virtual as Success Indicator and text virtual as Error message. The error message I get returned is “Start element 'Import' from namespace 'http://tempuri.org/' expected. Found element 'soapenv:Envelope' from namespace 'http://schemas.xmlsoap.org/soap/envelope/'. Line 1, position 377.”.   Any clues anyone can give would be appreciated . xpa 2.5d

 

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:tem="http://tempuri.org/" xmlns:mtp="http://schemas.datacontract.org/2004/07/MTP.Api.WebServices.JobsImport.Contract" xmlns:mtp1="http://schemas.datacontract.org/2004/07/MTP.Api.WebServices.Contracts">

   <soapenv:Header/>

   <soapenv:Body>

      <tem:Import>

         <tem:request>

            <mtp:Jobs>

               <mtp1:Job>

                  <mtp1:JobNumber>5</mtp1:JobNumber>

                  <mtp1:Weight>10.5</mtp1:Weight>

                  <mtp1:Cube>2.75</mtp1:Cube>

                  <mtp1:Duration>PT5M</mtp1:Duration>

                  <mtp1:Revenue>10</mtp1:Revenue>

                  <mtp1:JobTypes>type1</mtp1:JobTypes>

                  <mtp1:Skills>TL</mtp1:Skills>

                  <mtp1:CompanyName>TAP V3</mtp1:CompanyName>

                  <mtp1:CompanyPostcode>EH54 5NS</mtp1:CompanyPostcode>

                  <mtp1:CompanyAddressLine1>The Green Dragon Hotel</mtp1:CompanyAddressLine1>

                  <mtp1:CompanyAddressLine2></mtp1:CompanyAddressLine2>

                  <mtp1:CompanyCity>Hereford</mtp1:CompanyCity>

                  <mtp1:Notes>lorem ipsum</mtp1:Notes>

               </mtp1:Job>

            </mtp:Jobs>

            <mtp:UserName>mark.whelan@...</mtp:UserName>

         </tem:request>

      </tem:Import>

   </soapenv:Body>

</soapenv:Envelope>

 


Document Type WS

Jackson, Adam
 

Hi,

 

I am struggling to get a Document type WS working using Invoke WS Lite. I have only used RPC types before so unsure of the details of what I need to do. The payload I am trying to send is below. I got the endpoint working fine and it specified one parameter. I am sending the payload below as a variable type parameter. I have tried to send as an expression parameter but get same result. I am using a logical virtual as Success Indicator and text virtual as Error message. The error message I get returned is “Start element 'Import' from namespace 'http://tempuri.org/' expected. Found element 'soapenv:Envelope' from namespace 'http://schemas.xmlsoap.org/soap/envelope/'. Line 1, position 377.”.   Any clues anyone can give would be appreciated . xpa 2.5d

 

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:tem="http://tempuri.org/" xmlns:mtp="http://schemas.datacontract.org/2004/07/MTP.Api.WebServices.JobsImport.Contract" xmlns:mtp1="http://schemas.datacontract.org/2004/07/MTP.Api.WebServices.Contracts">

   <soapenv:Header/>

   <soapenv:Body>

      <tem:Import>

         <tem:request>

            <mtp:Jobs>

               <mtp1:Job>

                  <mtp1:JobNumber>5</mtp1:JobNumber>

                  <mtp1:Weight>10.5</mtp1:Weight>

                  <mtp1:Cube>2.75</mtp1:Cube>

                  <mtp1:Duration>PT5M</mtp1:Duration>

                  <mtp1:Revenue>10</mtp1:Revenue>

                  <mtp1:JobTypes>type1</mtp1:JobTypes>

                  <mtp1:Skills>TL</mtp1:Skills>

                  <mtp1:CompanyName>TAP V3</mtp1:CompanyName>

                  <mtp1:CompanyPostcode>EH54 5NS</mtp1:CompanyPostcode>

                  <mtp1:CompanyAddressLine1>The Green Dragon Hotel</mtp1:CompanyAddressLine1>

                  <mtp1:CompanyAddressLine2></mtp1:CompanyAddressLine2>

                  <mtp1:CompanyCity>Hereford</mtp1:CompanyCity>

                  <mtp1:Notes>lorem ipsum</mtp1:Notes>

               </mtp1:Job>

            </mtp:Jobs>

            <mtp:UserName>mark.whelan@...</mtp:UserName>

         </tem:request>

      </tem:Import>

   </soapenv:Body>

</soapenv:Envelope>

 

4381 - 4400 of 196209