Date   

Unipass / xpa and ram usage

Tim Downie
 

Hi
In unipass we had a program that would loop doing http calls returning an xml blob and writing data into SQL. Slowly unipassruntime.exe would use RAM - around 1.9gb usage the engine  would crash.

In 3.2e it appears to use RAM but then peridodically clean itself up - however today this has failed and the mgxparuntime has crashed.
"<192054909090559808> 27/05/2020 15:20:20.748     [Error  ] - [MgGui.dll] System.OutOfMemoryException :"

Can any one shed any light on this - something to do with either http calls or heavy blob processing doesnt relasese memory , im updating the blob to null() every cycle.

I was hoping this problem was solved for good moving to 3.2e.


Storing Emoji's

Graham White
 

Hi all,

 

We have written an app that retrieves SMS’s from our provider and stores them in the our database.  This works fine except when the SMS message contains an emoji or similar which comes through in the form of \uD83D\uDE03.  Is there any way to store the actual emoji within a pervasive field and display back it so that it looks exactly how it was sent?

 

Regards

 

Graham White
Software Developer
Graham.White@...
EC Credit Control |  eccreditcontrol.com

 

IMPORTANT NOTICE: This e-mail message and any attachments are confidential to EC Credit Control and subject to legal privilege (which is not waived or 

lost by mistaken delivery). If you have received this e-mail in error, please advise the sender immediately and destroy the message and any attachments.  

If you are not the intended recipient you are notified that any use, distribution, amendment, copying or any action taken or omitted to be taken in reliance of 

this message or attachments is prohibited. EC Credit Control collects personal information to provide and market our services (see our privacy policy at: 

www.eccreditcontrol.co.nz – www.eccreditcontrol.com - www.eccreditcontrol.com.au for more information about use, disclosure and access). 

EC Credit Control’s liability in connection with transmitting, unauthorised access to, or viruses in this message and its attachments is limited to resupply of 

any affected message or attachments.


Re: Nasty Locking-Problem magic 8.30 and PSQL8

David
 

I see. We never had such issues before, and even if this functionality seems basic to me it is probably not necessary in most cases.
You are right with the network issue, but to make the customer undestand his network is the problem will be a bigger task than making
the watchdog.. since they have no such effects on other software or on the hardware. The database seems just more sensitive

Since it's not happening all the time it should be enough to make a "kill on demand" instead of  a watchdog. Thank you so far.


Re: Nasty Locking-Problem magic 8.30 and PSQL8

Steven Blank
 

David,

Unfortunately, no such global timeout mechanism exists, even in current the version (v14), but if it continues to present a serious problem and you're unable to get your customer to address the network issues (obviously, the preferred solution), you could always roll your own watchdog.

It would certainly be possible, even in Magic v8.3 using MG_OCX.DLL, to develop such functionality utilizing the Pervasive Distributed Tuning Object's Monitor object (DTO.Monitor). In a nutshell, I would record logins and logouts in a table, and then, from time to time, check that list of active users with a list of active users obtained from DTO.Monitor and, when a user is found to be missing, use DTO.Monitor to disconnect the user's session. Such disconnect action also has the effect of releasing any locks the user might hold, as well as rolling back any transactions.

You might have to supplement with ping or somesuch along with DTO, but it all seems do-able.

Steve Blank

On 5/26/2020 2:40 PM, dm@... wrote:
Hello Steven

Thank you for your reply. I did the mentioned steps already. I controlled the clients today and made sure it's activated also there.
I will see tomorrow if it helps. I also raised the connection timeout hoping it helps to reconnect (standard is 15 sec...)
Sadly I think it will be the ID-Problem you mentioned and it would make the Auto-reconnect not the solution I'm looking for.

If only I could set a timeout after inactivity for the lock (or whole connection)....

regards

David


Re: Nasty Locking-Problem magic 8.30 and PSQL8

David
 

Hello Steven

Thank you for your reply. I did the mentioned steps already. I controlled the clients today and made sure it's activated also there.
I will see tomorrow if it helps. I also raised the connection timeout hoping it helps to reconnect (standard is 15 sec...)
Sadly I think it will be the ID-Problem you mentioned and it would make the Auto-reconnect not the solution I'm looking for.

If only I could set a timeout after inactivity for the lock (or whole connection)....

regards

David


Re: Display Issue with app running on iPad

Graham White
 

Hi Frederik,

No I didn't find a solution sadly.  I will be interested to hear if you do.

regards
Graham White


Re: Nasty Locking-Problem magic 8.30 and PSQL8

Steven Blank
 

Pervasive Auto Reconnect (PARC) has to be enabled in the PCC on both sides, client and server.

On the server, in Configure Local Engine:

and on the client workstation, in Configure Microkernel Router:

I recommend enabling PARC on the server and leaving it that way, then enabling it only on the problematic client(s) as needed.

Unfortunately, PARC isn't always able to reconnect a client, depending on whether or not the client continues to the use same 16-byte ClientID in its calls to the Btrieve API. In other words, if Magic crashes, the next time Magic starts up, it will gen another random ClientID and the server won't be able to match the returning client with an abandoned session. Typically, if Magic reports the lost communication, it's already gone too far to successfully reconnect. PARC is only designed to Band-Aid momentary network drops and, when successful, should prevent any such errors from even appearing in Magic.

Did you enable PARC on both sides and restart Pervasive Services on the server?

Steve Blank


On 5/26/2020 9:24 AM, dm@... wrote:
Hello

A customer is using magic 8.30 application with PSQL 8 (Btrieve) and we have some nasty connection problems.
From time to time (sadly more often lately) the customer network has connection drops...  long
enough to make the application struggle. It closes with an "connection to host", fetch error or Fatal Error message.

Wouldn't be a problem if after restarting erverything would work... but we then have a deadlock... the record which
was opened stays locked and never resolves.. The only help so far was to 1. reboot the server or 2. delete the user in
the pervasive monitor.

Is there a setting or something to prevent those deadlocks? a timeout maybe? I'm tired of having my sleep stolen
to kill a user in a database monitor....

The Auto-reconnect setting doesn't seem to work or change anything...

Would be glad if someone know this issue and has a solution for it :)
or something to resolve those locked records by script?
Restarting the server is not an option while several user work with the application

Kind regards


Nasty Locking-Problem magic 8.30 and PSQL8

David
 

Hello

A customer is using magic 8.30 application with PSQL 8 (Btrieve) and we have some nasty connection problems.
From time to time (sadly more often lately) the customer network has connection drops...  long
enough to make the application struggle. It closes with an "connection to host", fetch error or Fatal Error message.

Wouldn't be a problem if after restarting erverything would work... but we then have a deadlock... the record which
was opened stays locked and never resolves.. The only help so far was to 1. reboot the server or 2. delete the user in
the pervasive monitor.

Is there a setting or something to prevent those deadlocks? a timeout maybe? I'm tired of having my sleep stolen
to kill a user in a database monitor....

The Auto-reconnect setting doesn't seem to work or change anything...

Would be glad if someone know this issue and has a solution for it :)
or something to resolve those locked records by script?
Restarting the server is not an option while several user work with the application

Kind regards


magicweb.io

Oded Lavee
 

hi all
2 new lessons were added at the development section ( debugging and housekeeping)

fell free to ask any question...
in 4.7 some new features are coming.. stay tuned..


Re: Display Issue with app running on iPad

Frederik Soete
 

Hi Graham,

Some of my co-workers are updating an app from xpa 3.2 to xpa 3.3 because they
need to use a new Xcode version for publishing it. They experience the same
form sizing issue as you did in february. We would like to know if you have
found some solution to the issue?

Thanks in advance,

Frederik Soete


Hi,

 

We have an issue with a form displaying incorrectly on an iPad.  This has arisen since an update of Magic or IOS which we are not sure.  The attachment shows the form within the studio at the correct resolution for the iPad, however, when it displays in runtime the whole thing seems to be enlarged and only ¾ of the form is visible in the frame both vertically and horizontally.  The rest of it is there but you have to move it to the left or upwards to see what is outside the frame.  This is a subform displayed within a Tab control.


Any help would be most appreciated.

 

Graham White


Re: Locked out of studio with msg I've never seen before

Steven Blank
 

John,

Glad you got it sorted.

As you noted, the uniPaaS v1.9 Studio must be run in administrator mode in modern operating systems, if it was installed in the default location (%ProgramFiles(x86)%).

Steve Blank


On 5/25/2020 5:05 PM, Santana John wrote:
Hi, Steve,

Thanks for your help. The mglock.dat files I had already cleaned up. I had not thought of the .lock files. I found one that looked like it might be suspect, and removed it, but got the same error. Tried several things, and then, whistling in the dark, I tried opening uniPaaS in administrator mode, and, presto, that worked. I then tried opening it again not using admin, and that works also.

So maybe a file that I removed fixed it and there was a delay before the task read the change, or as usual, I got lucky.

Back to work, now. And I again thank you for your help.

John

On Mon, May 25, 2020 at 2:49 PM Steven Blank <sgblank@...> wrote:

John,

Try this: With the studio closed, search your local hard drive for any abandoned mglock.dat files, and delete any found.

HTH.

Steve Blank

On 5/25/2020 1:06 PM, Santana John wrote:
Hi, I sure hope someone knows what I need to do here.

Using good ol' uniPaaS 1.9p, Windows 10, as I have for years with no problems. Suddenly today I get this dialog:

Screenshot.jpg

I've restarted Mr. Computer and checked everything I know to check, but I still get this message. I'm hoping there's something easy to fix here. I expect a complete uninstall and reinstall might fix it, but it just might not. 

I should mention that there are no other running computers my network.

It looks like it might be an entry in some MSE file I don't know about, or maybe a registry value went haywire. If you know what this is about, I sure would appreciate your taking the time to respond. I've use Magic since it first came out in the 80s, and seen many a strange message, but this is yet another first. Just when you think you've seen it all....

Thanks,
John


Re: Locked out of studio with msg I've never seen before

Santana John
 

Hi, Steve,

Thanks for your help. The mglock.dat files I had already cleaned up. I had not thought of the .lock files. I found one that looked like it might be suspect, and removed it, but got the same error. Tried several things, and then, whistling in the dark, I tried opening uniPaaS in administrator mode, and, presto, that worked. I then tried opening it again not using admin, and that works also.

So maybe a file that I removed fixed it and there was a delay before the task read the change, or as usual, I got lucky.

Back to work, now. And I again thank you for your help.

John

On Mon, May 25, 2020 at 2:49 PM Steven Blank <sgblank@...> wrote:

John,

Try this: With the studio closed, search your local hard drive for any abandoned mglock.dat files, and delete any found.

HTH.

Steve Blank

On 5/25/2020 1:06 PM, Santana John wrote:
Hi, I sure hope someone knows what I need to do here.

Using good ol' uniPaaS 1.9p, Windows 10, as I have for years with no problems. Suddenly today I get this dialog:

Screenshot.jpg

I've restarted Mr. Computer and checked everything I know to check, but I still get this message. I'm hoping there's something easy to fix here. I expect a complete uninstall and reinstall might fix it, but it just might not. 

I should mention that there are no other running computers my network.

It looks like it might be an entry in some MSE file I don't know about, or maybe a registry value went haywire. If you know what this is about, I sure would appreciate your taking the time to respond. I've use Magic since it first came out in the 80s, and seen many a strange message, but this is yet another first. Just when you think you've seen it all....

Thanks,
John


Re: Locked out of studio with msg I've never seen before

Steven Blank
 

John,

Also, check the folder in which the EDP file is stored and delete any *.lock file you see there.

Steve Blank

On 5/25/2020 1:06 PM, Santana John wrote:
Hi, I sure hope someone knows what I need to do here.

Using good ol' uniPaaS 1.9p, Windows 10, as I have for years with no problems. Suddenly today I get this dialog:

Screenshot.jpg

I've restarted Mr. Computer and checked everything I know to check, but I still get this message. I'm hoping there's something easy to fix here. I expect a complete uninstall and reinstall might fix it, but it just might not. 

I should mention that there are no other running computers my network.

It looks like it might be an entry in some MSE file I don't know about, or maybe a registry value went haywire. If you know what this is about, I sure would appreciate your taking the time to respond. I've use Magic since it first came out in the 80s, and seen many a strange message, but this is yet another first. Just when you think you've seen it all....

Thanks,
John


Re: Locked out of studio with msg I've never seen before

Steven Blank
 

John,

Try this: With the studio closed, search your local hard drive for any abandoned mglock.dat files, and delete any found.

HTH.

Steve Blank

On 5/25/2020 1:06 PM, Santana John wrote:
Hi, I sure hope someone knows what I need to do here.

Using good ol' uniPaaS 1.9p, Windows 10, as I have for years with no problems. Suddenly today I get this dialog:

Screenshot.jpg

I've restarted Mr. Computer and checked everything I know to check, but I still get this message. I'm hoping there's something easy to fix here. I expect a complete uninstall and reinstall might fix it, but it just might not. 

I should mention that there are no other running computers my network.

It looks like it might be an entry in some MSE file I don't know about, or maybe a registry value went haywire. If you know what this is about, I sure would appreciate your taking the time to respond. I've use Magic since it first came out in the 80s, and seen many a strange message, but this is yet another first. Just when you think you've seen it all....

Thanks,
John


Locked out of studio with msg I've never seen before

Santana John
 

Hi, I sure hope someone knows what I need to do here.

Using good ol' uniPaaS 1.9p, Windows 10, as I have for years with no problems. Suddenly today I get this dialog:

Screenshot.jpg

I've restarted Mr. Computer and checked everything I know to check, but I still get this message. I'm hoping there's something easy to fix here. I expect a complete uninstall and reinstall might fix it, but it just might not. 

I should mention that there are no other running computers my network.

It looks like it might be an entry in some MSE file I don't know about, or maybe a registry value went haywire. If you know what this is about, I sure would appreciate your taking the time to respond. I've use Magic since it first came out in the 80s, and seen many a strange message, but this is yet another first. Just when you think you've seen it all....

Thanks,
John


Re: Huge Price Drop For Germ Protection Masks

Hershel Teitelbaum
 

which version Unipaas 1.9 or xpa 4.6?


Lost Focus with Call Program

Mulyadi Jet
 

Wondering if anyone had come up against this problem and if so
do you have any ideas for a work around. 

xpa 2.5c RIA

Parent (MDI Child) with Subform (Call Subtask : Child)
In Child Task, Main Data is Order File.
And in Child Task, there is a button with raise event to Call Program (New Order Entry).
If this button click, it calls the New Order Entry Program, but the cursor was still remain in the previous form (Order Line Form).
How can I make the cursor move to the called program's form ?

Any ideas ?

Cheers,

Mulyadi



Have you got Unipaas Runtime Licenses?

עזריאל ארד
 

if so, 
please contact me on azrielarad at gmail.com
thanks
Azriel


Re: How to reset Screen State automatically #xpa #ria

Wes Hein
 

Steve,

I guess I've never had the main screen appear off screen so I can't say about that, but have had modal windows decide to do so and the FormStateClear makes them visible again and remembers the proper location without requiring an exit/restart.

Wes


Re: How to reset Screen State automatically #xpa #ria

Steven Blank
 

Wes,

I'm likely wrong, but I don't believe that FormStateClear('*') will produce the OP's desired result, at least I have not been successful in achieving his goal just now, in my admittedly-limited testing.

Specifically, FormStateClear() is a Magic function and, as such, can only be evaluated while the MDI is open. As a result, one may indeed clear the current state of all open windows, but the final position and size of the MDI will always be saved again afterward, even after the Main Program's Task Suffix is executed, when the user exits the application.

Moreover, child windows' positions, sizes, etc. are saved in the Application Data folder, while the position and size of the MDI is saved in the registry, as a matter of standard OS functionality.

Steve Blank

3241 - 3260 of 195859