Date   

Web Service Lite

Pavel Mencl
 

Hi,
I'm in a tight spot here now,we use xpa 3.1 and consume WS via Invoke WS Lite,it's been working nicely for years,unfortunately the supplier changed the setup last week, I only hope someone will have the patience to weed through this with me.

This is the notice from our data supplier, obviously we've used the http connection. I continue below the insert.

=======================================
ACCESSING THE NEW PUBEASY VIA RETAILER API IS NOW AVAILABLE

 

Apologies for the delay but accessing the new Pubeasy via Retailer API is now available and we therefore need you to make a change to your back office system. This change depends on how you currently connect via your Retailer API as there are two setups for API connection: http and https.

 

The changes required for each connection are outlined below:

 

If your current connection is:

 

URL: https://soap.pubeasy.com/cgi-bin/SoapServer.pl 

Namespace: https://soap.pubeasy.com/CentralPEWS

If your current connection is:

 

URL: http://soap.pubeasy.com/cgi-bin/SoapServer.pl 

Namespace: http://soap.pubeasy.com/CentralPEWS

↓ 

Change your settings to:

 

NOTE: Namespace remains the same as you have now, only the URL needs to be changed.

 

URL: https://soap.pubnet.org/services/legacy/retailerSSL/

Namespace: https://soap.pubeasy.com/CentralPEWS

Change your settings to:

 

NOTE: The Namespace remains the same as you have now, only the URL needs to be changed.

 

Please note the https on the url, while the namespace remains as http

 

URL: https://soap.pubnet.org/services/legacy/retailer/

Namespace: http://soap.pubeasy.com/CentralPEWS


=======================================

I tried toto change the Endpoint of the service in the Services repository to : https://soap.pubnet.org/services/legacy/retailer/
but no good, I get this error:



Should I abandon WS Lite completely or there might be a way? Abandon will mean a lot of rewriting but I don't want to spend too much time finding a solution where none exists.
Any thoughts greatly appreciated.

Thanks
Pavel


Re: AutoComplete XPA 4.6

Steven Burrows
 

I complained HEAVILY about this, I don’t think we have a single control that is simple enough to not have an illegal picture of some sort, but doesn’t look like they see the point.

 

This wish is set with a low priority of enhancement.
As a result, we can only inform this issue to will be implemented with low level of importance.
But we cannot commit to implementing this feature in a specific version yet.

 

Google translate converted to:

 

“Why on earth would you want such pointless feature ? No chance matey, we have proper bugs to fix”

Steven Burrows

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Stefano Giusto via groups.io
Sent: 28 March 2021 12:05
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] AutoComplete XPA 4.6

 

This email is not from Hexagon’s Office 365 instance. Please be careful while clicking links, opening attachments, or replying to this email.

 

It is still broken in 4.7.1
only simple char pictures and nothing with numeric fields...
any news from MSE?
  Stefano


Re: AutoComplete XPA 4.6

Stefano Giusto
 

It is still broken in 4.7.1
only simple char pictures and nothing with numeric fields...
any news from MSE?
  Stefano


Re: Printer dialog not appearing

Wes Hein
 

KB5000802 was a fun one!  When using RDP, this update caused the BSOD with some printer drivers.

Wes


Re: Printer dialog not appearing

Ramon de Wit
 

Jef and Friedrich, thanks for your feedback!

 

I will check with the infra company of they installed the ‘fix’.

 

Fingers crossed!

 

 

 

 

Van: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] Namens Friedrich Geisler-Buckert
Verzonden: vrijdag 26 maart 2021 15:33
Aan: main@magicu-l.groups.io
Onderwerp: Re: [magicu-l] Printer dialog not appearing

 

There is an update

KB5001567

of this update, wich solved the problem for me.

Best regards

Friedrich


Re: Printer dialog not appearing

Friedrich Geisler-Buckert
 

There is an update

KB5001567

of this update, wich solved the problem for me.

Best regards

Friedrich


Re: Printer dialog not appearing

Jef Snijders
 

Kb5000802 should be removed from the installed Windows updates. 

Op vr 26 mrt. 2021 12:51 schreef Ramon de Wit <rwit@...>:

Hello group,

 

 

Apparently after a recent windows vulnerability update for some users the print dialog window doesn’t show anymore.

 

It is just simple reports with in the i/o file the pDlg property enabled. So really nothing much we can do.

 

XPA 2.x.

 

Anyone experiencing the same issue recently??? Hope this is now not an issue between 2.x and windows……

 

 

 

Thanks,

 

 

Ramon

 

 

 

Met vriendelijke groet,

 

 

 

Ramon de Wit

Mage - Magic Engineering

Postbus 36170

1020 MD Amsterdam

+31 (0)20 - 6325446

 


Re: Connecting to Excel with Interop

Friedrich Geisler-Buckert
 

On Fri, Mar 26, 2021 at 12:16 PM, Frederik Soete wrote:
Frederik
Hi Frederik,

thank you very much for youe fast answer!

I saw the Excel-Interface in the User Functionality - but I'm more a MAGIC programmer, than a C# one. May be I should change it.

But there is still the question: Why?

Best regards
Friedrich


Printer dialog not appearing

Ramon de Wit
 

Hello group,

 

 

Apparently after a recent windows vulnerability update for some users the print dialog window doesn’t show anymore.

 

It is just simple reports with in the i/o file the pDlg property enabled. So really nothing much we can do.

 

XPA 2.x.

 

Anyone experiencing the same issue recently??? Hope this is now not an issue between 2.x and windows……

 

 

 

Thanks,

 

 

Ramon

 

 

 

Met vriendelijke groet,

 

 

mage_logo_v3_emailfooter-02

 

Ramon de Wit

Mage - Magic Engineering

Postbus 36170

1020 MD Amsterdam

+31 (0)20 - 6325446

 


Re: Connecting to Excel with Interop

Frederik Soete
 

Hi, Friedrich,

Alternatively, you can create a C# snippet in Magic, i.e. "Invoke .Net". When our program wants to interface with Excel, we use snippets instead of Magic variables. As you see, there is no other way for Excel (because of the frustrating "...abstract..."). Snippets can also run faster than the alternative.

An Excel Interop example is included in the User Functionality EDP that Magic provides.

HTH,

Frederik Soete.

Op vr 26 mrt. 2021 11:44 schreef Friedrich Geisler-Buckert <Friedrich@...>:

Hi all,

i'm going crazy with the Interop.

This very simple progam in Visual Studio works fine


It just starts an empty EXCEL

Tryping to to the same with xpa 4.7:

Declaration of the variable works fine:


Trying to start a constructor:




"Can not create an instance of an abstract class or interface"

I can understand this message, but why is this in Visual studio possible?

Regards
Friedrich


Connecting to Excel with Interop

Friedrich Geisler-Buckert
 

Hi all,

i'm going crazy with the Interop.

This very simple progam in Visual Studio works fine


It just starts an empty EXCEL

Tryping to to the same with xpa 4.7:

Declaration of the variable works fine:


Trying to start a constructor:




"Can not create an instance of an abstract class or interface"

I can understand this message, but why is this in Visual studio possible?

Regards
Friedrich


TLS 1.2 on ClickOnce #ria #xpa

Darren
 

Hello Everyone,

Our application Supports TLS 1.2 but however for some reason, unless we force the client to add the registry key (SchUseStrongCrypto) like below, it won't use TLS 1.2 and we can't force our  4000+ clients/users to update their registry for it.

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\.NETFramework\v4.0.30319]
"SystemDefaultTlsVersions"=dword:00000001
"SchUseStrongCrypto"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]
"SystemDefaultTlsVersions"=dword:00000001
"SchUseStrongCrypto"=dword:00000001


However, using RIAModule desktop without clickonce works but we want to push it through Clickonce.

 

Regards,

Darren Jimenez


Re: Filecopy to network drive problem

Wes Hein
 

Copy the FIleCopy string to your clipboard when it executes and run the results from a cmd window, might return relevant information

Wes


Re: Filecopy to network drive problem

RJV
 

Just  a thought, Share and Directory access is arranged differently, worth to check that out in your case.

 

Kind regards / Hartelijke groeten / Z poważaniem / सधन्यवाद,

 

 

Rob Verheij

Of Govert Schipper via groups.io
Sent: Thursday, March 25, 2021 12:47 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Filecopy to network drive problem

 

Do you have a space in your network drive path?

Maybe enclose the full file path in double quotes.

 

 

 

Van: motifaithed@...
Verzonden: dinsdag 23 maart 2021 18:04
Aan: main@magicu-l.groups.io
Onderwerp: [magicu-l] Filecopy to network drive problem

 

Hi,

I would just like to ask everyone if they already bumped into the issue that I have today.

this code works on development mode(Magic XPA Studio runtime)

filecopy('C:\temp\test1.txt', '\\NetworkDrive\test1.txt')

But when I tried it on deployment mode(when the app is executed on my local machine). It doesn't work, no file copied on the network drive. All permissions are granted with read write delete.

I'm using magic xpa 3.3.

Please help it's been two days for this bug.

Thanks everyone :)

 

-----------------------------------------------------------------
ATTENTION:
The information in this e-mail is confidential and only meant for the intended recipient. If you are not the intended recipient, don't use or disclose it in any way. Please let the sender know and delete the message immediately.
-----------------------------------------------------------------


Re: Filecopy to network drive problem

Govert Schipper
 

Do you have a space in your network drive path?

Maybe enclose the full file path in double quotes.

 

 

 

Van: motifaithed@...
Verzonden: dinsdag 23 maart 2021 18:04
Aan: main@magicu-l.groups.io
Onderwerp: [magicu-l] Filecopy to network drive problem

 

Hi,

I would just like to ask everyone if they already bumped into the issue that I have today.

this code works on development mode(Magic XPA Studio runtime)

filecopy('C:\temp\test1.txt', '\\NetworkDrive\test1.txt')

But when I tried it on deployment mode(when the app is executed on my local machine). It doesn't work, no file copied on the network drive. All permissions are granted with read write delete.

I'm using magic xpa 3.3.

Please help it's been two days for this bug.

Thanks everyone :)

 


some license for sale #askmembers

Perkins.W.John@...
 

have some spare runtime and dev license no longer in use. does any body need. contact me to see if it can help.


Re: Filecopy to network drive problem

oldone
 

Had a variation of this with dos command executions failing with previous versions. Otherwise, unverified
experience.


Re: Web Client

Andreas Sedlmeier
 

I can imagine that the Web Client is better than you think, Craig ^^. Still I would not want to have that tight coupling either and would rather learn Angular where I then could have Magic on the backend as well. I think you have to learn it anyways when you work with Web Client


Re: Filecopy to network drive problem

Andreas Sedlmeier
 

Your path is ok for a 64-Bit version of Magic, it is however not relevant for a FileCopy operation anyways. Magic implements that natively and does not need a command shell to execute that operation.

How do you start your runtime engine which fails to copy the file to that network share ?

If the runtime is started by the broker running as LocalSystem you wont have access to any network drive

Best regards,

Andreas


On Tue, Mar 23, 2021 at 07:50 PM, <motifaithed@...> wrote:
On Wed, Mar 24, 2021 at 01:16 AM, Wes Hein wrote:
C:\Windows\system32\cmd.exe'

What should be the proper value for this one?


Re: Web Client

Craig Martin
 

Thanks for asking. I can only tell you my opinion only really applies to me.
Briefly, I simply don't want to be locked in for no good reason.

This is a Magic technology group, so I'll temper my response and arguments,
all I can say is now, I would choose other technologies. And even if I chose Angular
on the front end, I wouldn't have any desire to couple it so tightly to Magic.
Do your own thing for less trouble.

At this moment, I actually still make most of my earnings from Magic work,
so I also don't want to be either ungrateful or hypocritical.
But it's not really about me or my choices.

Someone who has made that choice and had success with web client in Production
needs to tell you why. I simply don't know such a person.
And it won't be my future-Self.

Go make it work. Be that guy.


From: main@magicu-l.groups.io <main@magicu-l.groups.io> on behalf of Govert Schipper <govertschipper@...>
Sent: Tuesday, March 23, 2021 2:33 AM
To: main@magicu-l.groups.io <main@magicu-l.groups.io>
Subject: Re: [magicu-l] Web Client
 

Hi Craig,

 

We our (very slowly) moving in the same direction as Tom.

You say browser client and web client are unlikely to be used in production systems.

Could you please elaborate on that and show us what alternatives you think are more viable?

Thanks.

 

Govert.

 

 

Van: Craig Martin
Verzonden: maandag 1 februari 2021 21:25
Aan: main@magicu-l.groups.io
Onderwerp: Re: [magicu-l] Web Client

 

Web client is interesting technology the same way webonline and browser client was.

And just as unlikely to be used in production systems.

There were some great presentations at the last Magic brown bag in Montreal for which video exists somewhere.

Was that only a year ago?

 

Let Magic do the backend if you must, but your frontend wants to be free.

This is only my feeling.

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> on behalf of Tom Worthen <tworthen@...>
Sent: Monday, February 1, 2021 6:48 AM
To: main@magicu-l.groups.io <main@magicu-l.groups.io>
Subject: [magicu-l] Web Client

 

We are considering moving into this area with some of our code. We are wondering if others are using this and whether you are satisfied with it or not?

If you are using it what did you migrate from?

What I mean by that is what part of xpa were you using prior to moving to web client?

Are you using it for internet or only intranet?

 

Thanks,

Tom

 

 

1881 - 1900 of 195968