Date   

Re: Drag & Drop XPA 4.7

De Netwerkadviseur BV
 

Hi Steven,

I use drop with 4.71 and have no problems.

Kind regards,
André


Re: Drag & Drop XPA 4.7

oldone
 

maybe a hole in the bucket, dear liza as the song once said...


Drag & Drop XPA 4.7

Steven Burrows
 

Anyone noticed that Drag&Drop into XPA no longer works (specifically Drop from an External Application) ?

Even the “Online Samples” seem broken

 

Steven Burrows

 


Font for menu and title bar [XPA4.7]

Florian Groothuis
 

Hi all,

Is it possible to change the fonttype that is used for the drop down menu and the title bar or is it inherited from the Windows theme?

Gr
Florian


Re: use of a tablet W10 with Magic 8.30

Friedrich Geisler-Buckert
 

Hi Jacques,

I'm impressed that this (at least 20 years old) version is still running under W10.

Personally I would not waste a second time to maintain such an old version - except migration to a newer version.

Is there an API (ActiveX/COM or .NET) from ACER or Windows to check the keyboard state?  If there is a .NET-API you have no chance with V8. Otherwise maybe?!

If there is an API you write e.g. an C#/VB-wrapper to check the keyboard state and set a flag e.g in the MAGIC.INI  

HTH

Best regards
Friedrich


Re: Magic TreeView XPA4.7

Olivier Besson
 

Hi Steven,

We have the same problem here and we have open a case at MSE support. They are supposed to correct it in the next release, hopefully soon
I played a little with the dotnet treeview but I failed to add images on the node

Olivier


Re: DirectSql and delete multiple tables #mssql

z_kenan@...
 

Yes, definitely stored procedure.
Direct SQL should be used only if you don't have a better approach.
With direct sql there is an additional issue of transaction processing related to Magic/xpa.
It is much easier and more safe to put that SQL code inside procedure.

Take care: If you are truncating tables / deleting data in 60 tables, you can't be sure if you are violating referential integrity.
The order of truncate statements could be an issue.

To safe on the safe side, I'd create procedure with return value - just to be 100% sure everything is OK.

Regards - Kenan


Re: C# Devexpress Xtrascheduler Non-static method requires a target

Vili CANKAR
 

Dear Friedrich,

I missed your mail, but thank you anyway...

I just did that and It do the trick... I could do with Magic from this:



to this:


And the code:



Argument for the net snippet is the XtraScheduler control.


Regards, Vili CANKAR

On 26. 05. 2021 07:56, Friedrich Geisler-Buckert wrote:
Hi Vili,

unfortunualy the .NET integration is not perfect in xpa :-(

I think it is not possible to update event-parameters. I spend days with trying to disable the default 'Click-Handler'  and use my own.

The solution is to create and register your own Handler in .NET Code


HTH

Best regards

Friedrich


-- 
Lep pozdrav, Vili


Re: Magic TreeView XPA4.7

Todd Baremore
 

Steven,

I've had success using a magic table control to drill down one or two layers. 
Todd
On 5/28/2021 11:46 AM, Steven Burrows wrote:

The Magic Treeview, is just plain flakey. Not sure I have it in me to try and get MSE Support to accept it, I have walls that need headbutting.

Opening and closing Folders/Nodes either with their fork of double click, or with the +- option works 95% of the time on my machine, 10% of the time on others. I have investigated the hell out of it, and it’s a Magic problem so need to look at an alternative.

 

Has anyone any experience (and example code!) of Windows Treeview which looks like a LOT of work, or if that is a bad choice, another option we might consider ?

 

Steven Burrows

 



Magic TreeView XPA4.7

Steven Burrows
 

The Magic Treeview, is just plain flakey. Not sure I have it in me to try and get MSE Support to accept it, I have walls that need headbutting.

Opening and closing Folders/Nodes either with their fork of double click, or with the +- option works 95% of the time on my machine, 10% of the time on others. I have investigated the hell out of it, and it’s a Magic problem so need to look at an alternative.

 

Has anyone any experience (and example code!) of Windows Treeview which looks like a LOT of work, or if that is a bad choice, another option we might consider ?

 

Steven Burrows

 


Re: Getting data from Google Analytics within a Magic program XPA 3.3g

JK Heydt
 

Is this something you do in Magic with client-server programming? Sounds interesting but I don't see the connection. TIA


Re: Expression Screen NOT showing

Wes Hein
 

You can also go the registry and just delete the key for the one item - Computer\HKEY_CURRENT_USER\SOFTWARE\MSE\Magic xpa lists the various options in xpa.  You can just delete the ExpressionEditor key so you don't get a complete reset of everything

Wes


Re: Getting data from Google Analytics within a Magic program XPA 3.3g

Andreas Sedlmeier
 

On Wed, May 26, 2021 at 11:00 PM, Graham White wrote:
Do I need to do something with the private key we received when registering the service account?
You need to do what the documentation tells, apply SHA256WithRSA to your message (that JSON). SHA256WithRSA gets the message and your private key as parameters. You then add the resulting byte string to the message and post that. You would not base64 encode it. 

A quick search for SHA256WithRSA implemented with .NET resulted in nothing. Java examples are easy to find.

Best regards,

Andreas


Re: Getting data from Google Analytics within a Magic program XPA 3.3g

Friedrich Geisler-Buckert
 

Hi Graham,

sounds complex - this not realy my skill.

I saw under https://jwt.io/ is a debbuger. Did you try to work with this?

Best regards
Friedrich


Re: Getting data from Google Analytics within a Magic program XPA 3.3g

Graham White
 

Hi Friedrich,

My initial problem is obtaining a token from Google for a service account.  I have to create a JWT Base64url encoded.  Below is the example they give at Using OAuth 2.0 for Server to Server Applications  |  Google Identity  

This is what it says at that link above

The signing algorithm in the JWT header must be used when computing the signature. The only signing algorithm supported by the Google OAuth 2.0 Authorization Server is RSA using SHA-256 hashing algorithm. This is expressed as RS256 in the alg field in the JWT header.

Sign the UTF-8 representation of the input using SHA256withRSA (also known as RSASSA-PKCS1-V1_5-SIGN with the SHA-256 hash function) with the private key obtained from the Google API Console. The output will be a byte array.

Below is an example of a JWT before Base64url encoding:
{"alg":"RS256","typ":"JWT"}.
{
"iss":"761326798069-r5mljlln1rd4lrbhg75efgigp36m78j5@...",
"scope":"https://www.googleapis.com/auth/prediction",
"aud":"https://oauth2.googleapis.com/token",
"exp":1328554385,
"iat":1328550785
}.
[signature bytes]

Based on that I have created 

{"alg":"RS256","typ":"JWT"}.
{
"iss":"EMAIL ADDRESS WE GOT",
"scope":"https://www.googleapis.com/auth/analytics.readonly",
"aud":"https://oauth2.googleapis.com/token",
"exp":1622108446,
"iat":1622104846
}.
{"OUR PRIVATE KEY"}

I then base64url encode it and use that in curl to get a token.  No matter what I do I always get

"error": "invalid_request",
  "error_description": "Bad Request"

I am a bit of a loss to figure out why.

I am unsure of exactly this means "Sign the UTF-8 representation of the input using SHA256withRSA (also known as RSASSA-PKCS1-V1_5-SIGN with the SHA-256 hash function) with the private key obtained from the Google API Console. The output will be a byte array."

Do I need to do something with the private key we received when registering the service account?  What am i missing?

I hope you or someone can help.

Regards
Graham White



Re: Expression Screen NOT showing

Jakes du Preez <dupreez.jakes@...>
 

There is a little Windows trick that may work.

Press <Alt>+<Spacebar> which will activate the context menu of the “hidden” active window. Press M to Move, then press one of the keyboard arrows. This will start to move the window; thereafter you can move the window by sliding your mouse. Left-clicking will drop it wherever your cursor is located



On 26 May 2021, at 07:46, Friedrich Geisler-Buckert <Friedrich@...> wrote:

Hi Kevin,

this can e.g. happen if you change form a 2-Monitor to Single-Monitor system. The Screen is just on the 'missing' screen.

There are  tow options to fix the problem:
  • delete the registry entry for xpa (of course it is like a reset after a new install)
  • try to catch the window an move it:
    1. open the hidden expression editor
    2. use ALT+Space+V to move the window
Btw; this happens in all xpa versions.

HTH
Best regards
Friedrich
 


Re: C# Devexpress Xtrascheduler Non-static method requires a target

Friedrich Geisler-Buckert
 

Hi Vili,

unfortunualy the .NET integration is not perfect in xpa :-(

I think it is not possible to update event-parameters. I spend days with trying to disable the default 'Click-Handler'  and use my own.

The solution is to create and register your own Handler in .NET Code


HTH

Best regards

Friedrich


Re: Expression Screen NOT showing

Friedrich Geisler-Buckert
 

Hi Kevin,

this can e.g. happen if you change form a 2-Monitor to Single-Monitor system. The Screen is just on the 'missing' screen.

There are  tow options to fix the problem:
  • delete the registry entry for xpa (of course it is like a reset after a new install)
  • try to catch the window an move it:
    1. open the hidden expression editor
    2. use ALT+Space+V to move the window
Btw; this happens in all xpa versions.

HTH
Best regards
Friedrich
 


Expression Screen NOT showing

Kevin Collins
 

Hey everyone, long time no talk. Hope everyone is doing well. I have the weirdest problem. v: XPA 3.3a
I've been working in this same environment for years, via Remote Desktop. All of a sudden when I double click/F5/Crtl-E the expression screen is invisible! You can tell the screen is loading as the menu options and the other visible parts of the screen are greyed out, but I can't see the expression list. When I hit escape the menu and other parts of the screen become active again. It acts as if it's loading the expression screen but I can't see it. I've tried expanding the screen into 2 monitors, shrinking the screen to see if it's loading behind, but nothing. It's the darndest thing. Has anyone else run into this? Did I change a setting somewhere accidentally??? TIA


use of a tablet W10 with Magic 8.30

Jacques
 

Hello Magicians,

Is there a way to find if a tablet is in tablet mode, or not?

My Acer tablet can have a keyboard, and i would like to change the way it works when the keyboard is, or is not connected to it.

With an "iniget somewhere something" ??

And as well, a way to activate the rotation lock ?

Thanks in advance for any hint

Jacques

1721 - 1740 of 195968