Date   

Re: Problems with DirDlg function in XPA 3.3

Jeroen Bos
 

Hi Viktoria,

 

If I look at the link from Microsoft, it is something for Windows 10, so it might be possible that this doesn’t work for Windows 7.

 

Met vriendelijke groet / Yours sincerely

De bronafbeelding bekijken
 

 


Jeroen Bos | Technisch Consultant (Technical Consultant)

Lekkerland Nederland B.V. | Ekkersrijt 7601 | 5692 HR Son

+31 (0) 40 264 4400 

jeroen.bos@...

www.lekkerland.nl | www.lekkerland24.nl

De bronafbeelding bekijken
 


Volg ons op              

 

 

Van: main@magicu-l.groups.io <main@magicu-l.groups.io> Namens Frigyesi Viktória via Groups.Io
Verzonden: vrijdag 7 februari 2020 08:40
Aan: main@magicu-l.groups.io
Onderwerp: Re: [magicu-l] Problems with DirDlg function in XPA 3.3

 

Hi Jeroen,

 

Is it possible that this setting is not available in Win7?

 

Thanks,

Viktoria

 

Feladó: Freddy Dewulf
Elküldve: 2020. február 7., péntek 8:39
Címzett: main@magicu-l.groups.io
Tárgy: Re: [magicu-l] Problems with DirDlg function in XPA 3.3

 

Hi Jeroen,
With this setting in the registry, the problem has been solved.
Thanks for the advice

Freddy

 

-------------------------------------------------------------------------------------------------
This e-mail may contain confidential and/or privileged information. If you are not the
intended receipient (or have received this e-mail in error) please notify the sender
immediately and destroy this e-mail.
Any unauthorised copying, disclosure or distribution of the material in this e-mail is strictly
forbidden.

Deze e-mail kan vertrouwelijke en/of persoonlijke informatie bevatten. Als u niet de bedoelde
ontvanger bent, of deze e-mail per ongeluk heeft gekregen, breng dan de verzender
ogenblikkelijk hiervan op de hoogte en vernietig dit bericht.
Het kopieren, in de openbaarheid brengen of verspreiden van de inhoud van deze e-mail is ten
strengste verboden.

Ce courriel peut contenir des informations confidentielles et/ou privilegiees. Si ce courriel ne vous est pas destine
(ou vous avez recu ce courriel par erreur) svp, avertissez immediatement la personne qui a envoye ce courriel et detruisez le.
Toute copie non autorisee, divulgation des informations ou distribution du contenu de ce courriel sont strictement interdites.
-------------------------------------------------------------------------------------------------


Re: Odd behavior with Row Expansion on Report in XPA 4.6

Steven Burrows
 

You have to add a CR/LF to get the last line to appear in Print Preview. Guess it’s the same with that Printer Driver, but I have only ever seen it with Print Preview.

Bound to be fixed soon, only been around since Magic v6.

 

Steven Burrows

 

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Jim Stephenson via Groups.Io
Sent: 06 February 2020 18:31
To: main@magicu-l.groups.io
Subject: [magicu-l] Odd behavior with Row Expansion on Report in XPA 4.6

 

This email is not from Hexagon’s Office 365 instance. Please be careful while clicking links, opening attachments, or replying to this email.

 

I have a report that prints notes chronologically. These notes can be up to 1000 characters. 

So I have my report set to expand the row to one page. I found something unusual though.

Some notes were getting their last line cut off. I expanded the field height which seemed to help somewhat.

But the thing is that if I print to a normal printer the notes print fine. If I print to the Adobe Printer driver it always chops off the last line of the text if it goes beyond 2 rows.

Is there something different that needs done when printing to a PDF this way?

Thanks,
Jim


Re: Problems with DirDlg function in XPA 3.3

Frigyesi Viktória
 

Hi Jeroen,

 

Is it possible that this setting is not available in Win7?

 

Thanks,

Viktoria

 

Feladó: Freddy Dewulf
Elküldve: 2020. február 7., péntek 8:39
Címzett: main@magicu-l.groups.io
Tárgy: Re: [magicu-l] Problems with DirDlg function in XPA 3.3

 

Hi Jeroen,
With this setting in the registry, the problem has been solved.
Thanks for the advice

Freddy

 


Re: Problems with DirDlg function in XPA 3.3

Freddy Dewulf
 

Hi Jeroen,
With this setting in the registry, the problem has been solved.
Thanks for the advice

Freddy


tcplus

oldone
 

anyone know or have worked with this product successfully?

Have a project that can fund its use.

Help if you know it or know someone who does.

thanks

don


Odd behavior with Row Expansion on Report in XPA 4.6

Jim Stephenson
 

I have a report that prints notes chronologically. These notes can be up to 1000 characters. 

So I have my report set to expand the row to one page. I found something unusual though.

Some notes were getting their last line cut off. I expanded the field height which seemed to help somewhat.

But the thing is that if I print to a normal printer the notes print fine. If I print to the Adobe Printer driver it always chops off the last line of the text if it goes beyond 2 rows.

Is there something different that needs done when printing to a PDF this way?

Thanks,
Jim


Re: Problems with DirDlg function in XPA 3.3

Jeroen Bos
 

Hi Freddy,

 

Somehow on windows 10 not all mapped drives are available in an elevated prompt. This can be changed via setting the registry key “HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\EnableLinkedConnections” to “1”. More background info on https://support.microsoft.com/en-us/help/3035277/mapped-drives-are-not-available-from-an-elevated-prompt-when-uac-is-co

 

Met vriendelijke groet / Yours sincerely

De bronafbeelding bekijken
 

 


Jeroen Bos | Technisch Consultant (Technical Consultant)

Lekkerland Nederland B.V. | Ekkersrijt 7601 | 5692 HR Son

+31 (0) 40 264 4400 

jeroen.bos@...

www.lekkerland.nl | www.lekkerland24.nl

De bronafbeelding bekijken
 


Volg ons op              

 

 

Van: main@magicu-l.groups.io <main@magicu-l.groups.io> Namens Freddy Dewulf via Groups.Io
Verzonden: maandag 27 januari 2020 09:47
Aan: main@magicu-l.groups.io
Onderwerp: [magicu-l] Problems with DirDlg function in XPA 3.3

 

Hello,
I have something strange in Magic (V7, Magic XPA 3.3).
When I look with Windows Explorer, I can see my local Drives, the mapped directories on the server and two drives, located in the cloud.
Drive N was created by installing Nuance Scansoft.
I installed a link to a kind of backup drive in the cloud (\u221809...). I mapped this to drive R.

In magic, I wiill select a map on the R drive. When I use the function DirDlg, the drives N and R are not shown, so I can't select the map.

When I copy a file located on the R drive, using FileCopy, nothing happens.
When I copy a file to the R drive or tot the N drive, using FileCopy, nothing happens.

When I execute a bat-file with a copy of that particular file, I get the message that the system can't find the file.

What could be the reason??
Are there any settings in the system (Win10) that influence this behaviour? 

Any suggestion is very wellcome.

tia
Freddy

-------------------------------------------------------------------------------------------------
This e-mail may contain confidential and/or privileged information. If you are not the
intended receipient (or have received this e-mail in error) please notify the sender
immediately and destroy this e-mail.
Any unauthorised copying, disclosure or distribution of the material in this e-mail is strictly
forbidden.

Deze e-mail kan vertrouwelijke en/of persoonlijke informatie bevatten. Als u niet de bedoelde
ontvanger bent, of deze e-mail per ongeluk heeft gekregen, breng dan de verzender
ogenblikkelijk hiervan op de hoogte en vernietig dit bericht.
Het kopieren, in de openbaarheid brengen of verspreiden van de inhoud van deze e-mail is ten
strengste verboden.

Ce courriel peut contenir des informations confidentielles et/ou privilegiees. Si ce courriel ne vous est pas destine
(ou vous avez recu ce courriel par erreur) svp, avertissez immediatement la personne qui a envoye ce courriel et detruisez le.
Toute copie non autorisee, divulgation des informations ou distribution du contenu de ce courriel sont strictement interdites.
-------------------------------------------------------------------------------------------------


Change 3D Colors V9.4

De Netwerkadviseur BV
 

Hi,

I don't remember exactly if it was possible to change the 3D Sunken/Raised colors of the TAB and the Rectangle objects with Magic v9.4SP8c.
Also the colors of the buttons and the backgroud? I do remember a part of the colors where fixed to the Windows thema colors.

I hope someone of you remembers.

Kind regards,
André


Re: Locking on Read

De Netwerkadviseur BV
 

Hi Peter and Viktor,

Thanks for your help. I already solved the problem by making a subtask with the link in it. This way the database is opened and directly closed, so only a very short lock.

Best regards,
André


Re: Locking on Read

Peter Ashworth
 

Hi André

If you need to keep the write mode in the higher task, but want to force the child task not to perform any locking. You can set in task properties, Enhanced tab, Data Management Options group box, Locking strategy=No Lock. The only downside to this is that you cant lock any records in other tables in the current task level either.

I don't see how you are getting the table lock rather then record lock, Normally that only comes into play if you do share=read or share=none.

HTH

Peter


Re: Locking on Read

lehoczki@...
 

Dear All,

Table lock can in 2 case:
1. You have a lot of Records locked so the DBMS Manager switch to table lock instead of record lock.
2. The settings in magic ini is set to Table lock.
Magic.ini
Databases menu
Database prroperty (ALT+ENTER)
Options TAB
Locking = Table

The settings can be:
None, Record, Table, Both

Best regards,

Viktor


Re: Error opening table that has a Blob attribute and contents on Unipaas 1.9C on Windows Server 2019 and Pervasive V8

lehoczki@...
 

Dear Marwin Mesa,
Never select blob in a dataview where more than 1 row can be a result.
Always select the records without blobs in the dataview. I always use a button on these screens and when the button is clicked I select the certain record again with the blob.
Similar like this
1. task parent
select
usercode
signid
filename
Last Date Signed
Last Time Signed
Used
Form
usercode signid filename Last Date Signed Last Time Signed Used

Button
When button clicked 1.1 subtask called
1.1 child task
select
unique index segments with range on each from the parent task. (I don't know what fields are unique in your file definition)
V... blob
S... blob
V... blob

In this case in the parent the blobs are not read from the database. For 1000 records 3 blobs can be a huge amount of data.
In the child task only 3 blobs are read from the database.
Best regards,
Viktor


Re: Strange keyboard issues in XPA 3.3?

Roberto Gauer
 

On 3.3c we found a bug with Kbput... Was overwriting text on edit if evaluated more times, on unselected text, where should append to the cursor parked text.

Only fix option was use a dotnet sendkeys instead.

We use for editing and save expressions for a later evarstr apply.

Em seg, 3 de fev de 2020 15:42, Frederik Soete <frederik.soete@...> escreveu:

Hi,

haven't checked, won't check.

Op ma 3 feb. 2020 17:08 schreef Roberto Gauer <gawarez@...>:
Thanks Frederik for this detailed job!

Since 4.x came from 3.3 branch... Is the same issues you found on 4.5 and 4.6? 

Em sex, 31 de jan de 2020 11:05, Frederik Soete <frederik.soete@...> escreveu:
Hi group,

I have collected some more raw data for the different releases of XPA >= 3.2d, and took down notes about the version numbers and release numbers.

Since XPA 3.3 a bad change in keyboard handling must have been introduced.

XPA version Release     Status
3.2.0.743 3.2d     Keyboard handling OK; does not have the bugs I mentioned.
3.2.0.756 3.2e     Keyboard handling OK; does not have the bugs I mentioned.
3.3.0.292 3.3     Multiple keyboard issues (i.e. the bugs I mentioned).
3.3.0.306 3.3a     Multiple keyboard issues
3.3.0.359 3.3b     Multiple keyboard issues
3.3.0.370 3.3c     Multiple keyboard issues
3.3.0.397 3.3d     Multiple keyboard issues
3.3.0.461 3.3e     Multiple keyboard issues (and also a bug related to buttons disappearing in tables)
(Unreleased) (3.3f)     (Unreleased)
3.3.0.494 3.3g     Multiple keyboard issues


More facts:
- Also, users report that once a problem occurs in Magic, it occurs everywhere else in Windows too.
- Others report yet other problems: problems regarding uppercase letters or the numeric keypad.
- Different users (not limited to just one OS, and on multiple sites here in Belgium) report different issues that all seem to start after an upgrade to a XPA 3.3 version.

Will report to MSE soon.


Re: Gigaspaces

tarcisio@...
 

Hi, group.

Well, i am using giga instead of broker in projects with until 350 users on line. 

We are having some problems, specially when producing large pdf files, and / or using blob fields in oracle. 

By the way, i think that giga is more stable than broker. 

But these projects are running under Magic XPA 3.3E, not in xpa 4.x.


Greetings,  Tarcisio 

Reta Systems - Brazil




Re: Strange keyboard issues in XPA 3.3?

Frederik Soete
 

Hi,

haven't checked, won't check.

Op ma 3 feb. 2020 17:08 schreef Roberto Gauer <gawarez@...>:

Thanks Frederik for this detailed job!

Since 4.x came from 3.3 branch... Is the same issues you found on 4.5 and 4.6? 

Em sex, 31 de jan de 2020 11:05, Frederik Soete <frederik.soete@...> escreveu:
Hi group,

I have collected some more raw data for the different releases of XPA >= 3.2d, and took down notes about the version numbers and release numbers.

Since XPA 3.3 a bad change in keyboard handling must have been introduced.

XPA version Release     Status
3.2.0.743 3.2d     Keyboard handling OK; does not have the bugs I mentioned.
3.2.0.756 3.2e     Keyboard handling OK; does not have the bugs I mentioned.
3.3.0.292 3.3     Multiple keyboard issues (i.e. the bugs I mentioned).
3.3.0.306 3.3a     Multiple keyboard issues
3.3.0.359 3.3b     Multiple keyboard issues
3.3.0.370 3.3c     Multiple keyboard issues
3.3.0.397 3.3d     Multiple keyboard issues
3.3.0.461 3.3e     Multiple keyboard issues (and also a bug related to buttons disappearing in tables)
(Unreleased) (3.3f)     (Unreleased)
3.3.0.494 3.3g     Multiple keyboard issues


More facts:
- Also, users report that once a problem occurs in Magic, it occurs everywhere else in Windows too.
- Others report yet other problems: problems regarding uppercase letters or the numeric keypad.
- Different users (not limited to just one OS, and on multiple sites here in Belgium) report different issues that all seem to start after an upgrade to a XPA 3.3 version.

Will report to MSE soon.


Re: Strange keyboard issues in XPA 3.3?

Roberto Gauer
 

Thanks Frederik for this detailed job!

Since 4.x came from 3.3 branch... Is the same issues you found on 4.5 and 4.6? 

Em sex, 31 de jan de 2020 11:05, Frederik Soete <frederik.soete@...> escreveu:

Hi group,

I have collected some more raw data for the different releases of XPA >= 3.2d, and took down notes about the version numbers and release numbers.

Since XPA 3.3 a bad change in keyboard handling must have been introduced.

XPA version Release     Status
3.2.0.743 3.2d     Keyboard handling OK; does not have the bugs I mentioned.
3.2.0.756 3.2e     Keyboard handling OK; does not have the bugs I mentioned.
3.3.0.292 3.3     Multiple keyboard issues (i.e. the bugs I mentioned).
3.3.0.306 3.3a     Multiple keyboard issues
3.3.0.359 3.3b     Multiple keyboard issues
3.3.0.370 3.3c     Multiple keyboard issues
3.3.0.397 3.3d     Multiple keyboard issues
3.3.0.461 3.3e     Multiple keyboard issues (and also a bug related to buttons disappearing in tables)
(Unreleased) (3.3f)     (Unreleased)
3.3.0.494 3.3g     Multiple keyboard issues


More facts:
- Also, users report that once a problem occurs in Magic, it occurs everywhere else in Windows too.
- Others report yet other problems: problems regarding uppercase letters or the numeric keypad.
- Different users (not limited to just one OS, and on multiple sites here in Belgium) report different issues that all seem to start after an upgrade to a XPA 3.3 version.

Will report to MSE soon.


Re: Conversion from v9.4

Arch <Arch.Lineberger@...>
 

Thanks for your efforts. 

Arch Lineberger
203 N Main St
Belmont, NC 28012
704.461.1223


On Sun, Feb 2, 2020 at 4:28 AM Jacques <j.gander@...> wrote:
Hi Arch,

i found these 2 files :
Cnv-830-940.ctl
MDB_CONVERT.94
I do not know if they are of any use....
I will join them and hope the are the one you're looking at

Jacques 


Re: Conversion from v9.4

Arch <Arch.Lineberger@...>
 

Thanks Keith. I had tried loading the last SP of v11 that did not include v9Converter.exe. You need to load many of the various SP's to get the converter.

Arch Lineberger
203 N Main St
Belmont, NC 28012
704.461.1223


On Sat, Feb 1, 2020 at 7:11 PM Keith Canniff <kcanniff@...> wrote:

Arch,

 

I’ve put a copy of the v9Converter in the group’s file section.

 

Keith

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Arch
Sent: Saturday, February 1, 2020 10:13 AM
To: Magic Group <main@magicu-l.groups.io>
Subject: [magicu-l] Conversion from v9.4

 

Does anyone have a copy of v9converter.exe they could share?

 

Arch Lineberger

203 N Main St

Belmont, NC 28012

704.461.1223


Re: Conversion from v9.4

Jacques
 

Hi Arch,

i found these 2 files :
Cnv-830-940.ctl
MDB_CONVERT.94
I do not know if they are of any use....
I will join them and hope the are the one you're looking at

Jacques 


Re: Conversion from v9.4

Keith Canniff
 

Arch,

 

I’ve put a copy of the v9Converter in the group’s file section.

 

Keith

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Arch
Sent: Saturday, February 1, 2020 10:13 AM
To: Magic Group <main@magicu-l.groups.io>
Subject: [magicu-l] Conversion from v9.4

 

Does anyone have a copy of v9converter.exe they could share?

 

Arch Lineberger

203 N Main St

Belmont, NC 28012

704.461.1223