Default VC server


Florian Groothuis
 
Edited

Hi all,
I'm using Azure Devops as VC-server but I'm 'stuck' with 3 environments. I have a new application I want to add to a VC-server but the wizard doesn't prompt me for a server and the application is uploaded to the wrong server. Where is this default VC-server set?

This is with uniPaaS 1.9m

TIA
Florian


Micha Weiss
 

Florian,

There are some definitions in the EDP file

Micha

HUJI

 

 

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Florian Groothuis
Sent: Monday, September 2, 2019 9:44 AM
To: main@magicu-l.groups.io
Subject: [magicu-l] Default VC server

 

[Edited Message Follows]

Hi all,
I'm using Azure Devops as VC-server but I'm 'stuck' with 3 environments. I have a new application I want to add to a VC-server but the wizard doesn't prompt me for a server and the application is uploaded to the wrong server. Where is this default VC-server set?

This is with uniPaaS 1.9m

TIA
Florian


Florian Groothuis
 

I imported the application and checked the edp, there's nothing on the VC-server:


Govert Schipper
 

Hi Florian,

Did you create a new application before importing it? If yes, did you check the option "Create a new project in the Version Control database"?
I don't think you can upload an existing application to a VC Server using Magic, only manually.

Govert


Van: main@magicu-l.groups.io <main@magicu-l.groups.io> namens Florian Groothuis <magic@...>
Verzonden: maandag 2 september 2019 09:10
Aan: main@magicu-l.groups.io <main@magicu-l.groups.io>
Onderwerp: Re: [magicu-l] Default VC server
 
I imported the application and checked the edp, there's nothing on the VC-server:


Virusvrij. www.avast.com


Keith Canniff
 

Florian,

 

I’ve been using Azure DevOps since 2014 (then VisualStudio.com) and it has never given me an option of a server. As far as I know, it’s Microsoft’s VC and therefore they put your application wherever they want.  I have separate Azure servers for running the application, but it’s not directly connected to the VC.

 

Here’s my path for my company’s VC:

 

<VCProjPath val="https://integrateone.visualstudio.com/defaultcollection|KC-ASUS|6f76ac31-ab95-448b-a4ae-d74ecc251b0e"/>

 

It’s Microsoft’s website to access the source, and my computer’s name that was the original one that added the source to Azure DevOps.

 

I have other code from a different client that always starts with their environment name (designated by the company) followed by Microsoft’s designation. The first one uses VCS for management, the others use Git.

 

On-Prem versions of VCS worked differently, but we’re talking Azure DevOps. If there’s another way I’d be interested to hear it.

 

Keith

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Florian Groothuis
Sent: Monday, September 2, 2019 2:44 AM
To: main@magicu-l.groups.io
Subject: [magicu-l] Default VC server

 

Hi all,
I'm using Azure Devops as VC-server but I'm 'stuck' with 3 environments. I have a new application I want to add to a VC-server but the wizard doesn't prompt me for a server and the application is uploaded to the wrong server. Where is this default VC-server set?

TIA
Florian


Virus-free. www.avast.com


Florian Groothuis
 

Hi Keith,

The problem is that the server UP wrtes the application to is a server from my former employer where I have (had) access to. I also have my own space (with the same MS-ID) where I want to put that application, but as I said, I'm not given the choice.

I tried to work the other way around, move all the files to the server using VS2017 and then use the OpenFromServer-option but in all cases I got an error which had something to do with a project already existing somewhere.

I will try to rename all and try again by moving the files and then open from server...


Keith Canniff
 

Florian,

 

I had to do the same thing. If I remember correctly, I exported the application, setup the application connected to the new (my) location in DevOps, then did the import.

 

Keith

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Florian Groothuis
Sent: Monday, September 2, 2019 9:24 AM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Default VC server

 

Hi Keith,

The problem is that the server UP wrtes the application to is a server from my former employer where I have (had) access to. I also have my own space (with the same MS-ID) where I want to put that application, but as I said, I'm not given the choice.

I tried to work the other way around, move all the files to the server using VS2017 and then use the OpenFromServer-option but in all cases I got an error which had something to do with a project already existing somewhere.

I will try to rename all and try again by moving the files and then open from server...


Virus-free. www.avast.com


Florian Groothuis
 

The procedure I mentioned above didn't work. UP opens the application but it's not set to multi-user, i.e. no checkin/checkout option and everthing is modifiable.


Florian Groothuis
 

Ok, it worked! And it worked as follows:

- Create an application
- Import the application
- Choose Add to VC-server
- Choose the server (yes, now you get prompted!)
- Choose the project
- Go!


Roman Goldenberg
 

Hi Florian,
do you install version control provider on work station?
magic required version control provider to connect to VC-Server.
after installation if you have several client providers please check default source control provider location in registry ,
magic looking for this location to prompt for the server.
  1. Go to Start>Run.

  2. Type in: regedit. Then click OK. The Registry Editor will open.

  3. If you're using a 32-bit version of Windows: Go to HKEY_LOCAL_MACHINE\SOFTWARE\SourceCodeControlProvider\ProviderRegKey.

    If you're using a 64-bit version of Windows: Go to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SourceCodeControlProvider\ProviderRegKey.