XPA 4.7 and Git #xpa #git


Stefano Giusto
 

Hello,
we just updated to xpa 4.7 coming from 2.5
we are already using github and tortoise git for other development projects not using Magic tools
If I try to use version control with 4.7 it says that SCC provider is missing.
How to get tortoise git pluging work?
Is Magic compare and merge worth the cost?
thank you
  Stefano


Stefano Giusto
 

Hello,
I am trying to put git working.
The git plugin is active if you have git.exe in your path (the error message is 'Version Control Provider was not found')
now that I fixed that (thank you Yuval) I am facing new difficulties.
I am following the 'Connecting Magic XPA with Git Repository' guide, but it is not clear.
I created a new project in a folder
then from file->version control I selected Create repository and confirmed with ok.
after that a window opens with 2 errors: Compare & Merge utility, Developer ID
if I close that window, the project closed with the error 'unable to open project' and I will be unable to open it unless I delete the .git folder
The compare & merge utility is mandatory? Can I use some other merge utility? (we do not plan of needing such a tool, we will work in a 'last commit wins' scenario). If it is mandatory, it should be shipped with XPA for free.
How to specify Developer ID?
Thank you
  Stefano


Andreas Sedlmeier
 

I have no idea regarding XPA 4.7 and Git. I use Git for single developer where one can do no harm.
If you have multiple developers working on a repository without that compare & Merge tool I think there's a good chance that you constantly destroy your repos.
MSE cannot provide such a tool themselves. Thats quite a shame but I think its not that expensive so add it to the costs.

Andreas


Moni‘s Gschichten <mobiel.muc@...>
 

Hi, compare &merge License is required – you need to contact the relevant Magic branch.it’s not shipped for free within xpa V4.7

 

Von: Stefano Giusto
Gesendet: Dienstag, 26. Januar 2021 22:11
An: main@magicu-l.groups.io
Betreff: Re: [magicu-l] XPA 4.7 and Git #git #xpa

 

Hello,
I am trying to put git working.
The git plugin is active if you have git.exe in your path (the error message is 'Version Control Provider was not found')
now that I fixed that (thank you Yuval) I am facing new difficulties.
I am following the 'Connecting Magic XPA with Git Repository' guide, but it is not clear.
I created a new project in a folder
then from file->version control I selected Create repository and confirmed with ok.
after that a window opens with 2 errors: Compare & Merge utility, Developer ID
if I close that window, the project closed with the error 'unable to open project' and I will be unable to open it unless I delete the .git folder
The compare & merge utility is mandatory? Can I use some other merge utility? (we do not plan of needing such a tool, we will work in a 'last commit wins' scenario). If it is mandatory, it should be shipped with XPA for free.
How to specify Developer ID?
Thank you
  Stefano