Travel-agent demo from magicweb.io


Tom Worthen
 

I am attempting to get this running but apparently I have a setting that is not correct. L

 

I have xpa 4.7 installed. I downloaded the application and have it running in background. I downloaded node.js and installed the Angular CLI. I have updated the server-config.json file but I think I don’t have the line correct for the requestor because it can’t find it. I have tried about 3 different ways of referencing it and none of them have worked. Can someone point me to what that setting should be?

 

I have tried setting it similar to what I would for a web page and it doesn’t find the dll. I have set it to the file somewhat directly and still it can’t find the dll.

 

So, my question is what should this line look like: “requestor”:”MagicScripts/MGrqispi.dll”,

 

I am sure that MGrqispi.dll is correct and probably what is before the colon is correct. So, what should I have in place of MagicScripts? My xpa installation is at c:\MSE\xpa47 with the scrips folder being in that folder and of course the dll is in the scripts folder. My entry in IIS for this is xpaScripts. The physical path for that is C:\MSE\xpa47\Scripts.

 

Hopefully someone can understand what I have put here and help me out. J

 

Thanks,

Tom

 


Rob Westland
 

Have you installded IIS before you installed XPA 4.7?

When Magic can find the IIS-server it automatically installs the rights paths in IIS.

what error do you get with:  http(s)://localhost/MagicScripts/MGrqisp.dll

a) it can't find the dll at all -> path setting in IIS is not correct

b) it can be found, but it wants to be downloaded -> the dll is not set as executable

c) it works


Rob

Op 8-2-2021 om 22:23 schreef Tom Worthen:

I am attempting to get this running but apparently I have a setting that is not correct. L

 

I have xpa 4.7 installed. I downloaded the application and have it running in background. I downloaded node.js and installed the Angular CLI. I have updated the server-config.json file but I think I don’t have the line correct for the requestor because it can’t find it. I have tried about 3 different ways of referencing it and none of them have worked. Can someone point me to what that setting should be?

 

I have tried setting it similar to what I would for a web page and it doesn’t find the dll. I have set it to the file somewhat directly and still it can’t find the dll.

 

So, my question is what should this line look like: “requestor”:”MagicScripts/MGrqispi.dll”,

 

I am sure that MGrqispi.dll is correct and probably what is before the colon is correct. So, what should I have in place of MagicScripts? My xpa installation is at c:\MSE\xpa47 with the scrips folder being in that folder and of course the dll is in the scripts folder. My entry in IIS for this is xpaScripts. The physical path for that is C:\MSE\xpa47\Scripts.

 

Hopefully someone can understand what I have put here and help me out. J

 

Thanks,

Tom

 


Tom Worthen
 

Rob,

 

IIS was installed on this server long before xpa 4.7. Actually this server was running xpa 3.2 until we installed 4.7.

 

You did put me on the correct path I think. I had not tried opening a jpg that is in that folder to see if it could find it. I found part of the issue in doing that exercise. That got me past the complaint about not being able to find the dll.

 

Now I just have a message saying the site can’t be reached. L

 

We do have our own in-house created security on the server which I logged into our site first and then tried hitting :4200 and got this new message. If I replace the :4200 with the path do one of the jpg’s in the folder it opens. If I set it to the dll it just sits there with a plain white page. I presume that means it works.

 

Any idea why it won’t run the program?

 

Thanks,

Tom

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent: Monday, February 08, 2021 4:46 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Travel-agent demo from magicweb.io

 

Have you installded IIS before you installed XPA 4.7?

When Magic can find the IIS-server it automatically installs the rights paths in IIS.

what error do you get with:  http(s)://localhost/MagicScripts/MGrqisp.dll

a) it can't find the dll at all -> path setting in IIS is not correct

b) it can be found, but it wants to be downloaded -> the dll is not set as executable

c) it works

 

Rob

Op 8-2-2021 om 22:23 schreef Tom Worthen:

I am attempting to get this running but apparently I have a setting that is not correct. L

 

I have xpa 4.7 installed. I downloaded the application and have it running in background. I downloaded node.js and installed the Angular CLI. I have updated the server-config.json file but I think I don’t have the line correct for the requestor because it can’t find it. I have tried about 3 different ways of referencing it and none of them have worked. Can someone point me to what that setting should be?

 

I have tried setting it similar to what I would for a web page and it doesn’t find the dll. I have set it to the file somewhat directly and still it can’t find the dll.

 

So, my question is what should this line look like: “requestor”:”MagicScripts/MGrqispi.dll”,

 

I am sure that MGrqispi.dll is correct and probably what is before the colon is correct. So, what should I have in place of MagicScripts? My xpa installation is at c:\MSE\xpa47 with the scrips folder being in that folder and of course the dll is in the scripts folder. My entry in IIS for this is xpaScripts. The physical path for that is C:\MSE\xpa47\Scripts.

 

Hopefully someone can understand what I have put here and help me out. J

 

Thanks,

Tom

 


Rob Westland
 

Next step: do you see something happening on the broker?

https://localhost/MagicScripts/MGrqispi.dll?APPNAME=xxx&PRGNAME=yyy

It should give you the famous Magic blue screen saying it can't find a Magic Engine


Op 8-2-2021 om 23:14 schreef Tom Worthen:

Rob,

 

IIS was installed on this server long before xpa 4.7. Actually this server was running xpa 3.2 until we installed 4.7.

 

You did put me on the correct path I think. I had not tried opening a jpg that is in that folder to see if it could find it. I found part of the issue in doing that exercise. That got me past the complaint about not being able to find the dll.

 

Now I just have a message saying the site can’t be reached. L

 

We do have our own in-house created security on the server which I logged into our site first and then tried hitting :4200 and got this new message. If I replace the :4200 with the path do one of the jpg’s in the folder it opens. If I set it to the dll it just sits there with a plain white page. I presume that means it works.

 

Any idea why it won’t run the program?

 

Thanks,

Tom

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent: Monday, February 08, 2021 4:46 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Travel-agent demo from magicweb.io

 

Have you installded IIS before you installed XPA 4.7?

When Magic can find the IIS-server it automatically installs the rights paths in IIS.

what error do you get with:  http(s)://localhost/MagicScripts/MGrqisp.dll

a) it can't find the dll at all -> path setting in IIS is not correct

b) it can be found, but it wants to be downloaded -> the dll is not set as executable

c) it works

 

Rob

Op 8-2-2021 om 22:23 schreef Tom Worthen:

I am attempting to get this running but apparently I have a setting that is not correct. L

 

I have xpa 4.7 installed. I downloaded the application and have it running in background. I downloaded node.js and installed the Angular CLI. I have updated the server-config.json file but I think I don’t have the line correct for the requestor because it can’t find it. I have tried about 3 different ways of referencing it and none of them have worked. Can someone point me to what that setting should be?

 

I have tried setting it similar to what I would for a web page and it doesn’t find the dll. I have set it to the file somewhat directly and still it can’t find the dll.

 

So, my question is what should this line look like: “requestor”:”MagicScripts/MGrqispi.dll”,

 

I am sure that MGrqispi.dll is correct and probably what is before the colon is correct. So, what should I have in place of MagicScripts? My xpa installation is at c:\MSE\xpa47 with the scrips folder being in that folder and of course the dll is in the scripts folder. My entry in IIS for this is xpaScripts. The physical path for that is C:\MSE\xpa47\Scripts.

 

Hopefully someone can understand what I have put here and help me out. J

 

Thanks,

Tom

 


Tom Worthen
 

Are you indicating attempting to run one of the public programs in the WebClientDemo App?

 

If so I tried and got this:

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent: Monday, February 08, 2021 5:19 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Travel-agent demo from magicweb.io

 

Next step: do you see something happening on the broker?

https://localhost/MagicScripts/MGrqispi.dll?APPNAME=xxx&PRGNAME=yyy

It should give you the famous Magic blue screen saying it can't find a Magic Engine

 

Op 8-2-2021 om 23:14 schreef Tom Worthen:

Rob,

 

IIS was installed on this server long before xpa 4.7. Actually this server was running xpa 3.2 until we installed 4.7.

 

You did put me on the correct path I think. I had not tried opening a jpg that is in that folder to see if it could find it. I found part of the issue in doing that exercise. That got me past the complaint about not being able to find the dll.

 

Now I just have a message saying the site can’t be reached. L

 

We do have our own in-house created security on the server which I logged into our site first and then tried hitting :4200 and got this new message. If I replace the :4200 with the path do one of the jpg’s in the folder it opens. If I set it to the dll it just sits there with a plain white page. I presume that means it works.

 

Any idea why it won’t run the program?

 

Thanks,

Tom

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent: Monday, February 08, 2021 4:46 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Travel-agent demo from magicweb.io

 

Have you installded IIS before you installed XPA 4.7?

When Magic can find the IIS-server it automatically installs the rights paths in IIS.

what error do you get with:  http(s)://localhost/MagicScripts/MGrqisp.dll

a) it can't find the dll at all -> path setting in IIS is not correct

b) it can be found, but it wants to be downloaded -> the dll is not set as executable

c) it works

 

Rob

Op 8-2-2021 om 22:23 schreef Tom Worthen:

I am attempting to get this running but apparently I have a setting that is not correct. L

 

I have xpa 4.7 installed. I downloaded the application and have it running in background. I downloaded node.js and installed the Angular CLI. I have updated the server-config.json file but I think I don’t have the line correct for the requestor because it can’t find it. I have tried about 3 different ways of referencing it and none of them have worked. Can someone point me to what that setting should be?

 

I have tried setting it similar to what I would for a web page and it doesn’t find the dll. I have set it to the file somewhat directly and still it can’t find the dll.

 

So, my question is what should this line look like: “requestor”:”MagicScripts/MGrqispi.dll”,

 

I am sure that MGrqispi.dll is correct and probably what is before the colon is correct. So, what should I have in place of MagicScripts? My xpa installation is at c:\MSE\xpa47 with the scrips folder being in that folder and of course the dll is in the scripts folder. My entry in IIS for this is xpaScripts. The physical path for that is C:\MSE\xpa47\Scripts.

 

Hopefully someone can understand what I have put here and help me out. J

 

Thanks,

Tom

 


Rob Westland
 

I just tried to figure out where the line was broken.

So it seems it's up and running all the way to the magic engine.

Now you have to setup the Magic settings. (I think)

Did you take a look at: https://webclient.magicsoftware.com/hands-on


Op 8-2-2021 om 23:23 schreef Tom Worthen:

Are you indicating attempting to run one of the public programs in the WebClientDemo App?

 

If so I tried and got this:

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent: Monday, February 08, 2021 5:19 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Travel-agent demo from magicweb.io

 

Next step: do you see something happening on the broker?

https://localhost/MagicScripts/MGrqispi.dll?APPNAME=xxx&PRGNAME=yyy

It should give you the famous Magic blue screen saying it can't find a Magic Engine

 

Op 8-2-2021 om 23:14 schreef Tom Worthen:

Rob,

 

IIS was installed on this server long before xpa 4.7. Actually this server was running xpa 3.2 until we installed 4.7.

 

You did put me on the correct path I think. I had not tried opening a jpg that is in that folder to see if it could find it. I found part of the issue in doing that exercise. That got me past the complaint about not being able to find the dll.

 

Now I just have a message saying the site can’t be reached. L

 

We do have our own in-house created security on the server which I logged into our site first and then tried hitting :4200 and got this new message. If I replace the :4200 with the path do one of the jpg’s in the folder it opens. If I set it to the dll it just sits there with a plain white page. I presume that means it works.

 

Any idea why it won’t run the program?

 

Thanks,

Tom

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent: Monday, February 08, 2021 4:46 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Travel-agent demo from magicweb.io

 

Have you installded IIS before you installed XPA 4.7?

When Magic can find the IIS-server it automatically installs the rights paths in IIS.

what error do you get with:  http(s)://localhost/MagicScripts/MGrqisp.dll

a) it can't find the dll at all -> path setting in IIS is not correct

b) it can be found, but it wants to be downloaded -> the dll is not set as executable

c) it works

 

Rob

Op 8-2-2021 om 22:23 schreef Tom Worthen:

I am attempting to get this running but apparently I have a setting that is not correct. L

 

I have xpa 4.7 installed. I downloaded the application and have it running in background. I downloaded node.js and installed the Angular CLI. I have updated the server-config.json file but I think I don’t have the line correct for the requestor because it can’t find it. I have tried about 3 different ways of referencing it and none of them have worked. Can someone point me to what that setting should be?

 

I have tried setting it similar to what I would for a web page and it doesn’t find the dll. I have set it to the file somewhat directly and still it can’t find the dll.

 

So, my question is what should this line look like: “requestor”:”MagicScripts/MGrqispi.dll”,

 

I am sure that MGrqispi.dll is correct and probably what is before the colon is correct. So, what should I have in place of MagicScripts? My xpa installation is at c:\MSE\xpa47 with the scrips folder being in that folder and of course the dll is in the scripts folder. My entry in IIS for this is xpaScripts. The physical path for that is C:\MSE\xpa47\Scripts.

 

Hopefully someone can understand what I have put here and help me out. J

 

Thanks,

Tom

 


Tom Worthen
 

I tried that link from 2 different machines and get the same result, the requested URL was not found on this server.

 

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent: Monday, February 08, 2021 5:30 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Travel-agent demo from magicweb.io

 

I just tried to figure out where the line was broken.

So it seems it's up and running all the way to the magic engine.

Now you have to setup the Magic settings. (I think)

Did you take a look at: https://webclient.magicsoftware.com/hands-on

 

Op 8-2-2021 om 23:23 schreef Tom Worthen:

Are you indicating attempting to run one of the public programs in the WebClientDemo App?

 

If so I tried and got this:

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent: Monday, February 08, 2021 5:19 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Travel-agent demo from magicweb.io

 

Next step: do you see something happening on the broker?

https://localhost/MagicScripts/MGrqispi.dll?APPNAME=xxx&PRGNAME=yyy

It should give you the famous Magic blue screen saying it can't find a Magic Engine

 

Op 8-2-2021 om 23:14 schreef Tom Worthen:

Rob,

 

IIS was installed on this server long before xpa 4.7. Actually this server was running xpa 3.2 until we installed 4.7.

 

You did put me on the correct path I think. I had not tried opening a jpg that is in that folder to see if it could find it. I found part of the issue in doing that exercise. That got me past the complaint about not being able to find the dll.

 

Now I just have a message saying the site can’t be reached. L

 

We do have our own in-house created security on the server which I logged into our site first and then tried hitting :4200 and got this new message. If I replace the :4200 with the path do one of the jpg’s in the folder it opens. If I set it to the dll it just sits there with a plain white page. I presume that means it works.

 

Any idea why it won’t run the program?

 

Thanks,

Tom

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent: Monday, February 08, 2021 4:46 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Travel-agent demo from magicweb.io

 

Have you installded IIS before you installed XPA 4.7?

When Magic can find the IIS-server it automatically installs the rights paths in IIS.

what error do you get with:  http(s)://localhost/MagicScripts/MGrqisp.dll

a) it can't find the dll at all -> path setting in IIS is not correct

b) it can be found, but it wants to be downloaded -> the dll is not set as executable

c) it works

 

Rob

Op 8-2-2021 om 22:23 schreef Tom Worthen:

I am attempting to get this running but apparently I have a setting that is not correct. L

 

I have xpa 4.7 installed. I downloaded the application and have it running in background. I downloaded node.js and installed the Angular CLI. I have updated the server-config.json file but I think I don’t have the line correct for the requestor because it can’t find it. I have tried about 3 different ways of referencing it and none of them have worked. Can someone point me to what that setting should be?

 

I have tried setting it similar to what I would for a web page and it doesn’t find the dll. I have set it to the file somewhat directly and still it can’t find the dll.

 

So, my question is what should this line look like: “requestor”:”MagicScripts/MGrqispi.dll”,

 

I am sure that MGrqispi.dll is correct and probably what is before the colon is correct. So, what should I have in place of MagicScripts? My xpa installation is at c:\MSE\xpa47 with the scrips folder being in that folder and of course the dll is in the scripts folder. My entry in IIS for this is xpaScripts. The physical path for that is C:\MSE\xpa47\Scripts.

 

Hopefully someone can understand what I have put here and help me out. J

 

Thanks,

Tom

 


Rob Westland
 

Strange Magic...

I copied it from my url, but entering it in a new resulsts in a 404

https://webclient.magicsoftware.com


Op 8-2-2021 om 23:34 schreef Tom Worthen:

I tried that link from 2 different machines and get the same result, the requested URL was not found on this server.

 

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent: Monday, February 08, 2021 5:30 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Travel-agent demo from magicweb.io

 

I just tried to figure out where the line was broken.

So it seems it's up and running all the way to the magic engine.

Now you have to setup the Magic settings. (I think)

Did you take a look at: https://webclient.magicsoftware.com/hands-on

 

Op 8-2-2021 om 23:23 schreef Tom Worthen:

Are you indicating attempting to run one of the public programs in the WebClientDemo App?

 

If so I tried and got this:

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent: Monday, February 08, 2021 5:19 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Travel-agent demo from magicweb.io

 

Next step: do you see something happening on the broker?

https://localhost/MagicScripts/MGrqispi.dll?APPNAME=xxx&PRGNAME=yyy

It should give you the famous Magic blue screen saying it can't find a Magic Engine

 

Op 8-2-2021 om 23:14 schreef Tom Worthen:

Rob,

 

IIS was installed on this server long before xpa 4.7. Actually this server was running xpa 3.2 until we installed 4.7.

 

You did put me on the correct path I think. I had not tried opening a jpg that is in that folder to see if it could find it. I found part of the issue in doing that exercise. That got me past the complaint about not being able to find the dll.

 

Now I just have a message saying the site can’t be reached. L

 

We do have our own in-house created security on the server which I logged into our site first and then tried hitting :4200 and got this new message. If I replace the :4200 with the path do one of the jpg’s in the folder it opens. If I set it to the dll it just sits there with a plain white page. I presume that means it works.

 

Any idea why it won’t run the program?

 

Thanks,

Tom

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent: Monday, February 08, 2021 4:46 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Travel-agent demo from magicweb.io

 

Have you installded IIS before you installed XPA 4.7?

When Magic can find the IIS-server it automatically installs the rights paths in IIS.

what error do you get with:  http(s)://localhost/MagicScripts/MGrqisp.dll

a) it can't find the dll at all -> path setting in IIS is not correct

b) it can be found, but it wants to be downloaded -> the dll is not set as executable

c) it works

 

Rob

Op 8-2-2021 om 22:23 schreef Tom Worthen:

I am attempting to get this running but apparently I have a setting that is not correct. L

 

I have xpa 4.7 installed. I downloaded the application and have it running in background. I downloaded node.js and installed the Angular CLI. I have updated the server-config.json file but I think I don’t have the line correct for the requestor because it can’t find it. I have tried about 3 different ways of referencing it and none of them have worked. Can someone point me to what that setting should be?

 

I have tried setting it similar to what I would for a web page and it doesn’t find the dll. I have set it to the file somewhat directly and still it can’t find the dll.

 

So, my question is what should this line look like: “requestor”:”MagicScripts/MGrqispi.dll”,

 

I am sure that MGrqispi.dll is correct and probably what is before the colon is correct. So, what should I have in place of MagicScripts? My xpa installation is at c:\MSE\xpa47 with the scrips folder being in that folder and of course the dll is in the scripts folder. My entry in IIS for this is xpaScripts. The physical path for that is C:\MSE\xpa47\Scripts.

 

Hopefully someone can understand what I have put here and help me out. J

 

Thanks,

Tom

 


Tom Worthen
 

That is where I downloaded the app from and followed the instructions to get this setup this far. I can see the WebClientDemo in the broker along with our html merge app which was already there. So, I know that part is running. If you are not aware the app can be found under the DEMO.

 

I am just not sure how to get it to run? The URL they indicate to use does not work. I am wondering if it is an issue with the port 4200. They don’t mention any other way to execute it so I am at a loss.

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent: Monday, February 08, 2021 5:36 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Travel-agent demo from magicweb.io

 

Strange Magic...

I copied it from my url, but entering it in a new resulsts in a 404

https://webclient.magicsoftware.com

 

Op 8-2-2021 om 23:34 schreef Tom Worthen:

I tried that link from 2 different machines and get the same result, the requested URL was not found on this server.

 

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent: Monday, February 08, 2021 5:30 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Travel-agent demo from magicweb.io

 

I just tried to figure out where the line was broken.

So it seems it's up and running all the way to the magic engine.

Now you have to setup the Magic settings. (I think)

Did you take a look at: https://webclient.magicsoftware.com/hands-on

 

Op 8-2-2021 om 23:23 schreef Tom Worthen:

Are you indicating attempting to run one of the public programs in the WebClientDemo App?

 

If so I tried and got this:

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent: Monday, February 08, 2021 5:19 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Travel-agent demo from magicweb.io

 

Next step: do you see something happening on the broker?

https://localhost/MagicScripts/MGrqispi.dll?APPNAME=xxx&PRGNAME=yyy

It should give you the famous Magic blue screen saying it can't find a Magic Engine

 

Op 8-2-2021 om 23:14 schreef Tom Worthen:

Rob,

 

IIS was installed on this server long before xpa 4.7. Actually this server was running xpa 3.2 until we installed 4.7.

 

You did put me on the correct path I think. I had not tried opening a jpg that is in that folder to see if it could find it. I found part of the issue in doing that exercise. That got me past the complaint about not being able to find the dll.

 

Now I just have a message saying the site can’t be reached. L

 

We do have our own in-house created security on the server which I logged into our site first and then tried hitting :4200 and got this new message. If I replace the :4200 with the path do one of the jpg’s in the folder it opens. If I set it to the dll it just sits there with a plain white page. I presume that means it works.

 

Any idea why it won’t run the program?

 

Thanks,

Tom

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent: Monday, February 08, 2021 4:46 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] Travel-agent demo from magicweb.io

 

Have you installded IIS before you installed XPA 4.7?

When Magic can find the IIS-server it automatically installs the rights paths in IIS.

what error do you get with:  http(s)://localhost/MagicScripts/MGrqisp.dll

a) it can't find the dll at all -> path setting in IIS is not correct

b) it can be found, but it wants to be downloaded -> the dll is not set as executable

c) it works

 

Rob

Op 8-2-2021 om 22:23 schreef Tom Worthen:

I am attempting to get this running but apparently I have a setting that is not correct. L

 

I have xpa 4.7 installed. I downloaded the application and have it running in background. I downloaded node.js and installed the Angular CLI. I have updated the server-config.json file but I think I don’t have the line correct for the requestor because it can’t find it. I have tried about 3 different ways of referencing it and none of them have worked. Can someone point me to what that setting should be?

 

I have tried setting it similar to what I would for a web page and it doesn’t find the dll. I have set it to the file somewhat directly and still it can’t find the dll.

 

So, my question is what should this line look like: “requestor”:”MagicScripts/MGrqispi.dll”,

 

I am sure that MGrqispi.dll is correct and probably what is before the colon is correct. So, what should I have in place of MagicScripts? My xpa installation is at c:\MSE\xpa47 with the scrips folder being in that folder and of course the dll is in the scripts folder. My entry in IIS for this is xpaScripts. The physical path for that is C:\MSE\xpa47\Scripts.

 

Hopefully someone can understand what I have put here and help me out. J

 

Thanks,

Tom

 


Mike Moore
 

Tom, did you get this working?

Thank you.





From:        "Tom Worthen" <tworthen@...>
To:        "main@magicu-l.groups.io" <main@magicu-l.groups.io>
Date:        02/08/2021 12:41 PM
Subject:        Re: [magicu-l] Travel-agent demo from magicweb.io
Sent by:        main@magicu-l.groups.io



That is where I downloaded the app from and followed the instructions to get this setup this far. I can see the WebClientDemo in the broker along with our html merge app which was already there. So, I know that part is running. If you are not aware the app can be found under the DEMO.

 

I am just not sure how to get it to run? The URL they indicate to use does not work. I am wondering if it is an issue with the port 4200. They don’t mention any other way to execute it so I am at a loss.

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent:
Monday, February 08, 2021 5:36 PM
To:
main@magicu-l.groups.io
Subject:
Re: [magicu-l] Travel-agent demo from magicweb.io

 


Strange Magic...
I copied it from my url, but entering it in a new resulsts in a 404
https://webclient.magicsoftware.com
 

Op 8-2-2021 om 23:34 schreef Tom Worthen:

I tried that link from 2 different machines and get the same result, the requested URL was not found on this server.

 

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent:
Monday, February 08, 2021 5:30 PM
To:
main@magicu-l.groups.io
Subject:
Re: [magicu-l] Travel-agent demo from magicweb.io

 


I just tried to figure out where the line was broken.
So it seems it's up and running all the way to the magic engine.
Now you have to setup the Magic settings. (I think)
Did you take a look at: https://webclient.magicsoftware.com/hands-on
 

Op 8-2-2021 om 23:23 schreef Tom Worthen:

Are you indicating attempting to run one of the public programs in the WebClientDemo App?

 

If so I tried and got this:

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent:
Monday, February 08, 2021 5:19 PM
To:
main@magicu-l.groups.io
Subject:
Re: [magicu-l] Travel-agent demo from magicweb.io

 


Next step: do you see something happening on the broker?
https://localhost/MagicScripts/MGrqispi.dll?APPNAME=xxx&PRGNAME=yyy
It should give you the famous Magic blue screen saying it can't find a Magic Engine
 

Op 8-2-2021 om 23:14 schreef Tom Worthen:

Rob,

 

IIS was installed on this server long before xpa 4.7. Actually this server was running xpa 3.2 until we installed 4.7.

 

You did put me on the correct path I think. I had not tried opening a jpg that is in that folder to see if it could find it. I found part of the issue in doing that exercise. That got me past the complaint about not being able to find the dll.

 

Now I just have a message saying the site can’t be reached. L

 

We do have our own in-house created security on the server which I logged into our site first and then tried hitting :4200 and got this new message. If I replace the :4200 with the path do one of the jpg’s in the folder it opens. If I set it to the dll it just sits there with a plain white page. I presume that means it works.

 

Any idea why it won’t run the program?

 

Thanks,

Tom

 

From: main@magicu-l.groups.io [mailto:main@magicu-l.groups.io] On Behalf Of Rob Westland
Sent:
Monday, February 08, 2021 4:46 PM
To:
main@magicu-l.groups.io
Subject:
Re: [magicu-l] Travel-agent demo from magicweb.io

 


Have you installded IIS before you installed XPA 4.7?
When Magic can find the IIS-server it automatically installs the rights paths in IIS.
what error do you get with:  http(s)://localhost/MagicScripts/MGrqisp.dll
a) it can't find the dll at all -> path setting in IIS is not correct
b) it can be found, but it wants to be downloaded -> the dll is not set as executable
c) it works
 
Rob

Op 8-2-2021 om 22:23 schreef Tom Worthen:

I am attempting to get this running but apparently I have a setting that is not correct. L

 

I have xpa 4.7 installed. I downloaded the application and have it running in background. I downloaded node.js and installed the Angular CLI. I have updated the server-config.json file but I think I don’t have the line correct for the requestor because it can’t find it. I have tried about 3 different ways of referencing it and none of them have worked. Can someone point me to what that setting should be?

 

I have tried setting it similar to what I would for a web page and it doesn’t find the dll. I have set it to the file somewhat directly and still it can’t find the dll.

 

So, my question is what should this line look like: “requestor”:”MagicScripts/MGrqispi.dll”,

 

I am sure that MGrqispi.dll is correct and probably what is before the colon is correct. So, what should I have in place of MagicScripts? My xpa installation is at c:\MSE\xpa47 with the scrips folder being in that folder and of course the dll is in the scripts folder. My entry in IIS for this is xpaScripts. The physical path for that is C:\MSE\xpa47\Scripts.

 

Hopefully someone can understand what I have put here and help me out. J

 

Thanks,

Tom