Cannot print on a thermal receipt printer using Media = Printer


Lei Salcedo
 

Hello All, 

We have migrated our system to XPA 4.6 and found that our print program using Media=Printer doesn't work anymore using the same setup (redirected printing) and driver that we have on our old system.


This work perfectly in our production using our old system in uniPaaS.

Anyone has a clue about this please? It would be greatly appreciated as we've been working on this for quite a while now. 


Best Regards,
Lei


sherman levine
 

What is in the Exp/Var field? If it's a file, then you should be able to compare the file contents.
Is Printer1 defined as the same printer in both systems?



On 7/4/2021 6:01 PM, Lei Salcedo wrote:
Hello All, 

We have migrated our system to XPA 4.6 and found that our print program using Media=Printer doesn't work anymore using the same setup (redirected printing) and driver that we have on our old system.


This work perfectly in our production using our old system in uniPaaS.

Anyone has a clue about this please? It would be greatly appreciated as we've been working on this for quite a while now. 


Best Regards,
Lei



Lei Salcedo
 

@sherman
The value in Exp/Var field is set to the printer where they want to print the receipt So, it could be 'Printer1', 'Printer2', and the like. 
And yes Printer1 defined as the same printer in both systems.
Also as per checking, the Media=Printer settings will work if we connect the printer from the base machine and print directly throught it. No print redirection. 
If we print it through a print server (redirection) only the Media=Graphic printer works.