Disable Mouse Wheel special setting not working


Adrian Wick
 

I thought by disabling mouse wheel will not "scroll" trough the records in a table. Setting this to "Y" has no effect what so ever.
Or is this for something else?

Regards
A


Keith Canniff
 

Adrian,

 

Magic interacts with the mouse like a standard program. If the mouse wheel scrolls up/down in browsers, excel, word, etc, it will do the same in Magic.

 

The code below will force the mouse wheel to only scroll one line at a time while in your application regardless of its Windows setting (which by default is 3 lines).

 

In Main Program you can do the following:

 

  1. Create the following global variables

 

  1. In Main Program Task Prefix do the following

 

 

Note: The DotNet expression is this:

DotNet.System.Windows.Forms.SystemInformation.MouseWheelScrollLines

 

  1. Setup the following events in Main Program (the expressions on the right are: NOT(gMouseWheelDisableCheck)

 

 

 

For the above Events Previous Row and Next Row, The “Propagate” property is set to the following expression:

 

                gPropagateMouseWheel? OR KbGet(0)<>'<>'

 

 

If I remember correctly, that should do it.

 

Keith

 

From: main@magicu-l.groups.io <main@magicu-l.groups.io> On Behalf Of Adrian Wick
Sent: Tuesday, May 3, 2022 9:32 AM
To: main@magicu-l.groups.io
Subject: [magicu-l] Disable Mouse Wheel special setting not working #xpa3.3

 

I thought by disabling mouse wheel will not "scroll" trough the records in a table. Setting this to "Y" has no effect what so ever.
Or is this for something else?

Regards
A


Adrian Wick
 
Edited

Thank you Keith for this!

But what i have is a table of records and each record points to a pdf file which is displayed right side to the table.
The problem are pdf files with more than 1 page. If i click on the pdf dotnet component and use the mouse wheel
i should scroll the pdf ... instead it scrolls the records :)

So the workaround was to display this dotnet in a subform ... Now when i click on the dotnet pdf it has no records 
to scroll and it scrolls the pdf file.

Thank you
A


Adrian Wick
 
Edited

Solution without the subform!

1. I created a virtual variable vDisableScroll.
2. Created Control Prefix of  dotnet component and updated variable to TRUE.
3. Created Control Suffix of  dotnet component and updated variable to FALSE.
4. Than I created NEXT ROW and PREVIOUS ROW event with nothing under them and on the condition i put vDisableScroll variable.

So when i am not parked on the dotnet component the scroll works. As soon as i enter the dotnet component, scroll stops working
and i can scroll the pdf ...

Regards
A