Timing out broker requests


Jackson, Adam
 

Hi,

 

We run a broker to handle certain requests. All usually works fine but occasionally we get two long running requests that consume our two licenses for a protracted period and fail all subsequent requests. There is something obviously wrong that we need to get to the bottom of. However, in the meantime is there a timeout setting I can set to kill off long running processes so it is at least these ones that fail and others can proceed ok? There seem to be a few timeout settings but I am not clear which one, if any, will do what I need.

 

xPa 2.5d

 

Hope someone can help?

 

TIA

 

Adam

 

Adam

Jackson

Senior Manager, Operations and Digital Systems

T  +447949892482

 

E  adam.jackson@...

McLaren Formula 1 Team

McLaren Technology Centre

Chertsey Road, Woking

Surrey, GU21 4YH, UK

mclaren.com

Facebook

Instagram

LinkedIn

Twitter

YouTube

 

The contents of this e-mail are confidential and for the exclusive use of the intended recipient. If you are not the intended recipient you should not read, copy, retransmit or disclose its contents. If you have received this email in error please delete it from your system immediately and notify us either by email or telephone. The views expressed in this communication may not necessarily be the views held by McLaren Racing Limited.
McLaren Racing Limited, McLaren Technology Centre, Chertsey Road, Woking, Surrey, GU21 4YH, UK. Company Number: 01517478


Kenan Zahirovic
 

Hi Adam,
 
You can use "ContextInactivityTimeout" in your Magic.ini file.

"This setting determines the time, measured in tenths of seconds, that a user who is executing a RIA or browser-based program will stay connected to the Magic xpa application while actually being inactive (absence of client/server interaction)."
 
Default value is 864000 (24 hours)

However, you should find out the source of these long running requests, it's about your code/application.
And yes, it's a pain to detect it ;-(

Regards,
Kenan