Weird printig photo problem


Adrian Wick
 

Dear Wizards,

today i came across a weird printing problem. I have a photo on the form. The file is bmp. And everything works
as it should except on one computer. The area where the photo should be is completely black. I tried different photos
(jpg, gif, png ...) and every time the photo doesn't show and is completely black.



I also tried printing directly to PDF in magic ... No luck. Printing to other printers does exactly the same.
I also opened the photo, that is displayed on the form, sent it to the printer and it prints without a problem.

Any ideas what could be wrong?

Regards
A


Wes Hein
 

What is the transparency setting of the file?  Is the control color black and white or transparent?


Adrian Wick
 

Hello Wes,

the color used is number "6" which is original color set up by magic. It has a foreground "Windows text" and background "FFFFFFFF".
The image itself is not "transparent".

A


Harry Kleinsmit
 

Hi Adrian,

Did you try some of the special settings like :

SpecialImageResize4Printing

When this flag is set to Yes, images rendered on a printer device will be resized using a proprietary algorithm rather than that of StretchDIBits().


HighResolutionPrint

The internal mechanism that calculates the dimensions and location of controls on a form to be printed out has been improved for better accuracy. Existing reports that might have been affected by the improved mechanism may switch to the previous mechanism by setting this special flag to No.

OriginalImageLoad

 

Setting this flag to Y may solve apparent printing problems.

PScriptPrintNT

 

Some colored images are not printed well when printed to postscript printers. Setting this flag to Y may solve such a problem.


Best regards,
Harry Kleinsmit


Adrian Wick
 

Hi Harry! 

I did try HighResolutionPrint, but it had no effect ... Didn't know about the other specials. I will give it a try. Thank you!

A


Adrian Wick
 

I just tried all and no effect.

I really don't know what else to do ... I will try a simple image of jpg, copied, without border and see what happens.

A


Angel Alvarado
 

Hello Adrian Check if there is a windows update, it is possible that causes the problem.


Adrian Wick
 

Hi,

its not windows update. This computer got updated a week ago to windows 11. The same problem was before with windows 10 ...

A