Topics

XPA 3.2e Form Editor problems

Todd Baremore
 

Using ESC does not exit the form editor, I have to use Alt-F4
No response when using F5 or double clicking on the Font or Color number

Started this morning.   Any ideas?


Todd

Andy Jerison
 

Only that Ctrl+F4, the "close window" command, is safer. 


On Mon, Jun 24, 2019, 17:59 Todd Baremore <tbaremor@...> wrote:
Using ESC does not exit the form editor, I have to use Alt-F4
No response when using F5 or double clicking on the Font or Color number

Started this morning.   Any ideas?


Todd




Danica Majernikova
 

Todd,
did you upgrade Windows system?
After I upgraded to Windows 10, I have to use buttons fn+F5 for zooming in fonts and colours, or you have a little button with 3 dots on the very right side of the line, this is a zoom button.
ESC works fine for me.

Danica


From: main@magicu-l.groups.io <main@magicu-l.groups.io> on behalf of Todd Baremore <tbaremor@...>
Sent: June 24, 2019 5:59 PM
To: main@magicu-l.groups.io
Subject: [magicu-l] XPA 3.2e Form Editor problems
 
Using ESC does not exit the form editor, I have to use Alt-F4
No response when using F5 or double clicking on the Font or Color number

Started this morning.   Any ideas?


Todd




Todd Baremore
 

Danica,

You are correct, a Windows 10 update did run this morning.  I also can not use F4 to create a new line in the expression editor. Fn+F5 does not work for me with the form font and color. 

Andy,  Ctrl-F4 does not close the Form Editor.
Todd
On 6/24/2019 6:52 PM, Danica Majernikova wrote:

Todd,
did you upgrade Windows system?
After I upgraded to Windows 10, I have to use buttons fn+F5 for zooming in fonts and colours, or you have a little button with 3 dots on the very right side of the line, this is a zoom button.
ESC works fine for me.

Danica

From: main@magicu-l.groups.io <main@magicu-l.groups.io> on behalf of Todd Baremore <tbaremor@...>
Sent: June 24, 2019 5:59 PM
To: main@magicu-l.groups.io
Subject: [magicu-l] XPA 3.2e Form Editor problems
 
Using ESC does not exit the form editor, I have to use Alt-F4
No response when using F5 or double clicking on the Font or Color number

Started this morning.   Any ideas?


Todd





Danica Majernikova
 

Todd,
you still can use the little zoom button.
Fn+F4 creates lines for me in the expressions.
To close the form editor try ALT+F4

Danica


From: main@magicu-l.groups.io <main@magicu-l.groups.io> on behalf of Todd Baremore <tbaremor@...>
Sent: June 24, 2019 8:11 PM
To: main@magicu-l.groups.io
Subject: Re: [magicu-l] XPA 3.2e Form Editor problems
 
Danica,

You are correct, a Windows 10 update did run this morning.  I also can not use F4 to create a new line in the expression editor. Fn+F5 does not work for me with the form font and color. 

Andy,  Ctrl-F4 does not close the Form Editor.
Todd
On 6/24/2019 6:52 PM, Danica Majernikova wrote:
Todd,
did you upgrade Windows system?
After I upgraded to Windows 10, I have to use buttons fn+F5 for zooming in fonts and colours, or you have a little button with 3 dots on the very right side of the line, this is a zoom button.
ESC works fine for me.

Danica

From: main@magicu-l.groups.io <main@magicu-l.groups.io> on behalf of Todd Baremore <tbaremor@...>
Sent: June 24, 2019 5:59 PM
To: main@magicu-l.groups.io
Subject: [magicu-l] XPA 3.2e Form Editor problems
 
Using ESC does not exit the form editor, I have to use Alt-F4
No response when using F5 or double clicking on the Font or Color number

Started this morning.   Any ideas?


Todd





Wes Hein
 

Wes Hein
 

If you don't have access

Q2

Why aren’t the keyboard shortcuts, such as F4 and F5, working in the Expression Editor or the Form Designer?

A2

To solve this problem, you need to reset the keyboard shortcuts in Visual Studio back to defaults as follows:

1. Open any program and zoom to the Form Designer.

2. Click on the down arrow at the end of the first toolbar, click the Add or remove buttons option and select the Customize option. Note that some of the entries in this list, such as Save All, are Visual Studio default entries and have no effect on the Magic xpa screens.

3. In the Customize window, click the Keyboard button at the bottom of the screen.

4. In the Options screen, click Reset.

5. In the confirmation dialog box, select Yes.

That’s it. You might need to restart the Studio.

Wes

Roberto Gauer
 

Yesterday I was with this same issue... 
By a machine without the keyboard shortcuts problems, i found out a missing .VSK file, in folder AppData\Roaming\MSE\Magic xpa\3.3\TaskEditor.

The above Q/A answers the way to generate a new one... 

Great :)


On Tue, Jun 25, 2019 at 12:08 PM Wes Hein <wes@...> wrote:
If you don't have access

Q2

Why aren’t the keyboard shortcuts, such as F4 and F5, working in the Expression Editor or the Form Designer?

A2

To solve this problem, you need to reset the keyboard shortcuts in Visual Studio back to defaults as follows:

1. Open any program and zoom to the Form Designer.

2. Click on the down arrow at the end of the first toolbar, click the Add or remove buttons option and select the Customize option. Note that some of the entries in this list, such as Save All, are Visual Studio default entries and have no effect on the Magic xpa screens.

3. In the Customize window, click the Keyboard button at the bottom of the screen.

4. In the Options screen, click Reset.

5. In the confirmation dialog box, select Yes.

That’s it. You might need to restart the Studio.

Wes

Todd Baremore
 

Roberto & Wes,

I was able to fix it late last night, the explanation below explains why it worked.

I created a new Windows user account.  Logged in to Magic with the from the new windows account and everything worked as expected.  I then copied Roaming\mse  and Local\mse to my profile.  This worked but I did not know why.   Now I know. 

Thanks for your help.  
Todd
On 6/25/2019 3:03 PM, Roberto Gauer wrote:

Yesterday I was with this same issue... 
By a machine without the keyboard shortcuts problems, i found out a missing .VSK file, in folder AppData\Roaming\MSE\Magic xpa\3.3\TaskEditor.

The above Q/A answers the way to generate a new one... 

Great :)


On Tue, Jun 25, 2019 at 12:08 PM Wes Hein <wes@...> wrote:
If you don't have access

Q2

Why aren’t the keyboard shortcuts, such as F4 and F5, working in the Expression Editor or the Form Designer?

A2

To solve this problem, you need to reset the keyboard shortcuts in Visual Studio back to defaults as follows:

1. Open any program and zoom to the Form Designer.

2. Click on the down arrow at the end of the first toolbar, click the Add or remove buttons option and select the Customize option. Note that some of the entries in this list, such as Save All, are Visual Studio default entries and have no effect on the Magic xpa screens.

3. In the Customize window, click the Keyboard button at the bottom of the screen.

4. In the Options screen, click Reset.

5. In the confirmation dialog box, select Yes.

That’s it. You might need to restart the Studio.

Wes


Idris
 

thank you Wes... this saved or rather gave me a new life today :)